aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-18 14:22:40 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-19 02:20:59 -0800
commitbd2ad24d7bc31902d4797c23e38dd1c58a1d1c6c (patch)
tree0c500023caa15371c33bc9786a4a5e894690e4db /meta-oe/recipes-benchmark
parentce41fe5acab3c77ae7cc60dfe8a0b7fe443a1b4d (diff)
downloadmeta-openembedded-bd2ad24d7bc31902d4797c23e38dd1c58a1d1c6c.tar.gz
recipes: Make powerpc64le overrides
The existing conditions for ppc64/be are applicable for le as well Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/iozone3/iozone3_488.bb1
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/iozone3/iozone3_488.bb b/meta-oe/recipes-benchmark/iozone3/iozone3_488.bb
index 4d9e07765f..222a95647e 100644
--- a/meta-oe/recipes-benchmark/iozone3/iozone3_488.bb
+++ b/meta-oe/recipes-benchmark/iozone3/iozone3_488.bb
@@ -25,6 +25,7 @@ S = "${WORKDIR}/${BPN}_${PV}/src/current/"
#
EXTRA_OEMAKE_powerpc = "linux-powerpc CC='${CC}' GCC='${CC}'"
EXTRA_OEMAKE_powerpc64 = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
+EXTRA_OEMAKE_powerpc64le = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
EXTRA_OEMAKE_x86-64 = "linux-AMD64 CC='${CC}' GCC='${CC}'"
EXTRA_OEMAKE_arm = "linux-arm CC='${CC}' GCC='${CC}'"
EXTRA_OEMAKE = "linux CC='${CC}' GCC='${CC}'"
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index e66db1a090..f1a4efba26 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -37,6 +37,7 @@ LIBARGS = "LIB32=${baselib} LIB64=${baselib}"
LIBHUGETLBFS_ARCH = "${TARGET_ARCH}"
LIBHUGETLBFS_ARCH_powerpc = "ppc"
LIBHUGETLBFS_ARCH_powerpc64 = "ppc64"
+LIBHUGETLBFS_ARCH_powerpc64le = "ppc64"
EXTRA_OEMAKE = "'ARCH=${LIBHUGETLBFS_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} BUILDTYPE=NATIVEONLY V=2"
PARALLEL_MAKE = ""
CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0"