aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-11-10 14:25:57 -0800
committerKhem Raj <raj.khem@gmail.com>2021-11-11 06:36:53 -0800
commitc1968ea88caba65895cae58cca60742ff980ec1b (patch)
tree9ac1984da8154923dcde2a93b8298d0546dffa2c /meta-oe/recipes-benchmark
parentef4f5c1f3395f871b951cf03dd38993a101ab0e3 (diff)
downloadmeta-openembedded-c1968ea88caba65895cae58cca60742ff980ec1b.tar.gz
linpack: Build both sp and dp binaries
This eases out running single-precision and double-precision benchmarks. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/linpack/linpack/0001-linpack-Define-DP-only-when-SP-is-not-defined.patch32
-rw-r--r--meta-oe/recipes-benchmark/linpack/linpack_1.0.bb10
2 files changed, 39 insertions, 3 deletions
diff --git a/meta-oe/recipes-benchmark/linpack/linpack/0001-linpack-Define-DP-only-when-SP-is-not-defined.patch b/meta-oe/recipes-benchmark/linpack/linpack/0001-linpack-Define-DP-only-when-SP-is-not-defined.patch
new file mode 100644
index 0000000000..4eb18e38ca
--- /dev/null
+++ b/meta-oe/recipes-benchmark/linpack/linpack/0001-linpack-Define-DP-only-when-SP-is-not-defined.patch
@@ -0,0 +1,32 @@
+From f092d4be22acd09e791187b8e9bff6d312721ce4 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 10 Nov 2021 11:36:31 -0800
+Subject: [PATCH] linpack: Define DP only when SP is not defined
+
+This helps compiling two versions ( SP/FP ) of the benchmark just by
+passing -DSP on compile cmdline
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ linpacknew.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/linpacknew.c b/linpacknew.c
+index 17b2824..c656082 100644
+--- a/linpacknew.c
++++ b/linpacknew.c
+@@ -28,7 +28,9 @@
+ #include <time.h>
+ #include <float.h>
+
++#ifndef SP
+ #define DP
++#endif
+
+ #ifdef SP
+ #define ZERO 0.0
+--
+2.33.1
+
diff --git a/meta-oe/recipes-benchmark/linpack/linpack_1.0.bb b/meta-oe/recipes-benchmark/linpack/linpack_1.0.bb
index aed95cdaa4..603004ddd5 100644
--- a/meta-oe/recipes-benchmark/linpack/linpack_1.0.bb
+++ b/meta-oe/recipes-benchmark/linpack/linpack_1.0.bb
@@ -4,17 +4,21 @@ SUMMARY = "LINPACK is a software library for performing numerical linear algebra
LICENSE = "PD"
LIC_FILES_CHKSUM ="file://${WORKDIR}/linpacknew.c;beginline=1;endline=23;md5=aa025e3bc44190c71e4c5e3b084fed87"
-SRC_URI = "http://www.netlib.org/benchmark/linpackc.new;downloadfilename=linpacknew.c"
+SRC_URI = "http://www.netlib.org/benchmark/linpackc.new;downloadfilename=linpacknew.c \
+ file://0001-linpack-Define-DP-only-when-SP-is-not-defined.patch \
+ "
SRC_URI[md5sum] = "1c5d0b6a31264685d2e651c920e3cdf4"
SRC_URI[sha256sum] = "a63f2ec86512959f1fd926bfafb85905b2d7b7402942ffae3af374d48745e97e"
S = "${WORKDIR}"
do_compile () {
- ${CC} ${CFLAGS} ${LDFLAGS} -o linpack linpacknew.c -lm
+ ${CC} ${CFLAGS} ${LDFLAGS} -DDP -o linpack_dp linpacknew.c -lm
+ ${CC} ${CFLAGS} ${LDFLAGS} -DSP -o linpack_sp linpacknew.c -lm
}
do_install () {
- install -Dm 0755 linpack ${D}${bindir}/linpack
+ install -Dm 0755 linpack_dp ${D}${bindir}/linpack_dp
+ install -Dm 0755 linpack_sp ${D}${bindir}/linpack_sp
}