aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-17 20:31:32 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-18 16:49:57 -0800
commit8931598cc0c48440b336be548d51e1473fbe4d15 (patch)
tree61f521c870bbf337947ea4dc66cca7567168d958 /meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
parent1e1acb72c9fbf04eee34432506bdb44a20a95746 (diff)
downloadmeta-openembedded-8931598cc0c48440b336be548d51e1473fbe4d15.tar.gz
libtorrent: Disable instrumentation on ppc/mips
From https://github.com/rakshasa/rtorrent/issues/156 all atomics (__sync_fetch_and_and_8) are not avaliable on mips/ppc, this patch helps workaround the build error Fixes ld: libtorrent.so: undefined reference to `__sync_add_and_fetch_8' Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb')
-rw-r--r--meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
index a3902b25f6..3ee69554b6 100644
--- a/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
+++ b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
@@ -15,6 +15,13 @@ PV = "0.13.8"
S = "${WORKDIR}/git"
+PACKAGECONFIG ??= "instrumentation"
+
+PACKAGECONFIG_remove_mipsarch = "instrumentation"
+PACKAGECONFIG_remove_powerpc = "instrumentation"
+
+PACKAGECONFIG[instrumentation] = "--enable-instrumentation,--disable-instrumentation,"
+
inherit autotools pkgconfig
EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"