aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php/php_8.0.12.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-11-11 08:32:58 -0800
committerKhem Raj <raj.khem@gmail.com>2021-11-13 01:17:18 -0800
commitce3a46e874bebbe3b67d9d1fa1246622c7508c46 (patch)
treeeef6daa9f06a04267830990edb9ab2915f95ff4b /meta-oe/recipes-devtools/php/php_8.0.12.bb
parent7175f8b66980cad3299a2ff9001691af0015e5c0 (diff)
downloadmeta-openembedded-ce3a46e874bebbe3b67d9d1fa1246622c7508c46.tar.gz
php: Build minilua for build host
see https://bugs.php.net/bug.php?id=80717&edit=1 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php/php_8.0.12.bb')
-rw-r--r--meta-oe/recipes-devtools/php/php_8.0.12.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/php/php_8.0.12.bb b/meta-oe/recipes-devtools/php/php_8.0.12.bb
index 300499de5c..8d24c187ef 100644
--- a/meta-oe/recipes-devtools/php/php_8.0.12.bb
+++ b/meta-oe/recipes-devtools/php/php_8.0.12.bb
@@ -25,7 +25,7 @@ SRC_URI:append:class-target = " \
file://0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch \
file://0007-sapi-cli-config.m4-fix-build-directory.patch \
file://0008-ext-imap-config.m4-fix-include-paths.patch \
- file://0011-opcache-jit-use-minilua-in-sysroot.patch \
+ file://1010-Fix-opcache-jit-minilua-compiling.patch \
file://php-fpm.conf \
file://php-fpm-apache.conf \
file://70_mod_php${PHP_MAJOR_VERSION}.conf \
@@ -108,6 +108,7 @@ PACKAGECONFIG[valgrind] = "--with-valgrind=${STAGING_DIR_TARGET}/usr,--with-valg
PACKAGECONFIG[mbregex] = "--enable-mbregex, --disable-mbregex, oniguruma"
PACKAGECONFIG[mbstring] = "--enable-mbstring,,"
+export HOSTCC = "${BUILD_CC}"
export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"
export PHP_PEAR_PHP_BIN = "${STAGING_BINDIR_NATIVE}/php"
CFLAGS += " -D_GNU_SOURCE -g -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -I${STAGING_INCDIR}/apache2"
@@ -258,13 +259,8 @@ RCONFLICTS:${PN}-modphp = "${MODPHP_OLDPACKAGE}"
do_install:append:class-native() {
create_wrapper ${D}${bindir}/php \
PHP_PEAR_SYSCONF_DIR=${sysconfdir}/
-
- if [ "$MACHINE_ARCH" == "x86" || "$MACHINE_ARCH" == "x86-64" ]; then
- install -m 0755 ${WORKDIR}/build/ext/opcache/minilua ${D}${bindir}/
- fi
}
-
# Fails to build with thumb-1 (qemuarm)
# | {standard input}: Assembler messages:
# | {standard input}:3719: Error: selected processor does not support Thumb mode `smull r0,r2,r9,r3'