aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorDaniel Díaz <daniel.diaz@linaro.org>2018-06-27 12:43:51 -0500
committerKhem Raj <raj.khem@gmail.com>2018-06-27 22:17:33 -0700
commit00d5219d6515982ecdbe2f3c5d9eff852ef02589 (patch)
treed5c557db4f323593a4fd2703206faa0160cc3597 /meta-oe/recipes-kernel
parent38d227b2bd98af2db97031ccb1234159776d11a4 (diff)
downloadmeta-openembedded-00d5219d6515982ecdbe2f3c5d9eff852ef02589.tar.gz
bpftool: add new recipe
The bpftool allows for inspection and simple manipulation of eBPF programs and maps, so common in the kernel selftests. Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/bpftool/bpftool.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/bpftool/bpftool.bb b/meta-oe/recipes-kernel/bpftool/bpftool.bb
new file mode 100644
index 0000000000..fd0653ab87
--- /dev/null
+++ b/meta-oe/recipes-kernel/bpftool/bpftool.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Inspect and manipulate eBPF programs and maps"
+DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \
+of eBPF programs and maps."
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = "binutils elfutils"
+PROVIDES = "virtual/bpftool"
+
+inherit bash-completion kernelsrc kernel-arch
+
+do_populate_lic[depends] += "virtual/kernel:do_patch"
+
+EXTRA_OEMAKE = "-C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+python do_package_prepend() {
+ d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0])
+}
+
+B = "${WORKDIR}/${BPN}-${PV}"