aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2021-05-11 16:18:14 +0800
committerKhem Raj <raj.khem@gmail.com>2021-05-11 08:27:28 -0700
commit8cf040ac76ce3a1b4f96035a1d6355bb2f5b25c6 (patch)
treee2a47b175fe12056fac166d40a568cdf7c639534 /meta-oe
parentf6b4cb02314d91f76b747e4bfbd2ccdee807e2ec (diff)
downloadmeta-openembedded-8cf040ac76ce3a1b4f96035a1d6355bb2f5b25c6.tar.gz
nmap: change shebang to python3
upstream nmap is python2 compatiable now, but this recipe supports python3. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-security/nmap/nmap_7.80.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-oe/recipes-security/nmap/nmap_7.80.bb b/meta-oe/recipes-security/nmap/nmap_7.80.bb
index c76d2324e7..17bc40911d 100644
--- a/meta-oe/recipes-security/nmap/nmap_7.80.bb
+++ b/meta-oe/recipes-security/nmap/nmap_7.80.bb
@@ -50,9 +50,11 @@ do_configure() {
}
do_install_append() {
- if [ -f "${D}${bindir}/ndiff" ]; then
- sed -i 's@^#!.*$@#!/usr/bin/env python3@g' ${D}${bindir}/ndiff
- fi
+ for f in ndiff uninstall_ndiff; do
+ if [ -f ${D}${bindir}/$f ]; then
+ sed -i 's@^#!.*$@#!/usr/bin/env python3@g' ${D}${bindir}/$f
+ fi
+ done
}
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR} ${datadir}/ncat"