aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-cryptography_2.3.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-07-27 15:12:05 -0400
committerKhem Raj <raj.khem@gmail.com>2018-07-27 19:26:51 -0700
commit1fc824bf6c822346158d74bd86f9cf206723f23a (patch)
tree942f81b99769360e54e0610d75ae021a06e1a68b /meta-python/recipes-devtools/python/python-cryptography_2.3.bb
parent04d79442043e2d47ae9f968aff8894bdddde573a (diff)
downloadmeta-openembedded-1fc824bf6c822346158d74bd86f9cf206723f23a.tar.gz
python-cryptography: update to version 2.3
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-cryptography_2.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_2.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography_2.3.bb b/meta-python/recipes-devtools/python/python-cryptography_2.3.bb
new file mode 100644
index 0000000000..9c2f88418d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography_2.3.bb
@@ -0,0 +1,22 @@
+inherit pypi setuptools
+require python-cryptography.inc
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+DEPENDS += " \
+ ${PYTHON_PN}-enum34 \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-enum34 \
+ ${PYTHON_PN}-ipaddress \
+"
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-enum34 \
+ ${PYTHON_PN}-ipaddress \
+ ${PYTHON_PN}-contextlib \
+ ${PYTHON_PN}-subprocess \
+"