aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aenum_3.0.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-26 14:50:02 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-28 10:52:32 -0800
commitee864c09d6d7594b5a24398a0f9a65fe3bb22538 (patch)
tree2f435f913243246c162a1274fb71e6d81d73cfca /meta-python/recipes-devtools/python/python3-aenum_3.0.0.bb
parent79e2a520bc2ed1203bfd6304650a43898d0a76a0 (diff)
downloadmeta-openembedded-ee864c09d6d7594b5a24398a0f9a65fe3bb22538.tar.gz
python3-aenum: Upgrade 2.2.6 -> 3.0.0
Upgrade to release 3.0.0: - Flags only list single bit names, multi-bit are aliases - error checking to go with that - getattr magic is off for AutoValue - Member creation has been redone to match Python 3.10's methods. This also allows all supported Pythons (2.7, 3.3+) to use the __set_name__ and __init_subclass__ protocols (more robustly than in aenum 2.2.5) - enum_property() has been renamed to property() (old name still available, but deprecated) - bin() replacement shows negative integers in twos-complement Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aenum_3.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aenum_3.0.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aenum_3.0.0.bb b/meta-python/recipes-devtools/python/python3-aenum_3.0.0.bb
new file mode 100644
index 0000000000..cb8462d24e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aenum_3.0.0.bb
@@ -0,0 +1,10 @@
+SUMMARY = "Advanced Enumerations library"
+HOMEPAGE = "https://pypi.org/project/aenum/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://aenum/LICENSE;md5=c6a85477543f8b8591b9c1f82abebbe9"
+
+SRC_URI[sha256sum] = "17cd8cfed1ee4b617198c9fabbabd70ebd8f01e54ac29cd6c3a92df14bd86656"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"