aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aiofiles_0.7.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-17 14:11:28 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-19 09:16:54 -0700
commit1553993029710d34d622c2427b68cb45b896a445 (patch)
tree4f6753135210ca64d236c65d60b72cde3feea8a2 /meta-python/recipes-devtools/python/python3-aiofiles_0.7.0.bb
parentbe3f005dd79b3ebb8663ca3367d87db0ed60d8a0 (diff)
downloadmeta-openembedded-1553993029710d34d622c2427b68cb45b896a445.tar.gz
python3-aiofiles: Upgrade 0.6.0 -> 0.7.0
Upgrade to release 0.7.0: - Added the aiofiles.tempfile module for async temporary files. - Switched to Poetry and GitHub actions. - Dropped 3.5 support. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aiofiles_0.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiofiles_0.7.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiofiles_0.7.0.bb b/meta-python/recipes-devtools/python/python3-aiofiles_0.7.0.bb
new file mode 100644
index 0000000000..9d7a49eb63
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiofiles_0.7.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "File support for asyncio"
+DESCRIPTION = "Asynchronous local file IO library for asyncio and Python"
+HOMEPAGE = "https://github.com/aio-libs/aiohttp"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+SRC_URI[sha256sum] = "a1c4fc9b2ff81568c83e21392a82f344ea9d23da906e4f6a52662764545e19d4"
+
+PYPI_PACKAGE = "aiofiles"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-asyncio \
+"