aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-11-10 12:01:36 +0800
committerKhem Raj <raj.khem@gmail.com>2021-11-11 06:36:04 -0800
commitc5051f8f0a3c7cd9513dffdd449c608b0583a31c (patch)
treed65b7cefbcebf9655f5ffd44d60d5ccb821d0d26 /meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb
parente6292ce3c97573ecaeac61fedfec188b885fc1bb (diff)
downloadmeta-openembedded-c5051f8f0a3c7cd9513dffdd449c608b0583a31c.tar.gz
python3-async-timeout: upgrade 3.0.1 -> 4.0.0
License-Update: Description of license is replaced by website "http://www.apache.org/licenses/LICENSE-2.0" Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb b/meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb
new file mode 100644
index 0000000000..ca61490fac
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "asyncio-compatible timeout context manager"
+DESCRIPTION = "\
+The context manager is useful in cases when you want to apply \
+timeout logic around block of code or in cases when asyncio.wait_for() \
+is not suitable. Also it's much faster than asyncio.wait_for() because \
+timeout doesn't create a new task."
+HOMEPAGE = "https://github.com/aio-libs/async-timeout"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fa41f15bb5f23b6d3560c5845eb8d57"
+
+SRC_URI[sha256sum] = "7d87a4e8adba8ededb52e579ce6bc8276985888913620c935094c2276fd83382"
+
+PYPI_PACKAGE = "async-timeout"
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-asyncio \
+"