aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-blinker_1.4.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-02-23 23:36:38 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-24 08:30:26 -0800
commit47ce8529aba7effe5c6a16e069e19b2de99406f7 (patch)
tree4fbcb263f7ba8fb90de08b77c13af22e6d62e9d3 /meta-python/recipes-devtools/python/python3-blinker_1.4.bb
parent41457cc0a1ea1cb506a7fe86e70aff9ee8b1aad2 (diff)
downloadmeta-openembedded-47ce8529aba7effe5c6a16e069e19b2de99406f7.tar.gz
python3-blinker: Migrate to use pytest instead of nose for testing
Nose wont work well with python 3.9+ anyway Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-blinker_1.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-blinker_1.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-blinker_1.4.bb b/meta-python/recipes-devtools/python/python3-blinker_1.4.bb
index 397fdcfb05..08a961f938 100644
--- a/meta-python/recipes-devtools/python/python3-blinker_1.4.bb
+++ b/meta-python/recipes-devtools/python/python3-blinker_1.4.bb
@@ -8,12 +8,12 @@ SRC_URI[sha256sum] = "471aee25f3992bd325afa3772f1063dbdbbca947a041b8b89466dc00d6
inherit pypi setuptools3 ptest
SRC_URI += " \
+ file://0001-use-pytest-instead-of-deprecated-nose.patch \
file://run-ptest \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
- ${PYTHON_PN}-nose \
"
do_install_ptest() {