aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-15 12:43:10 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-16 12:52:19 -0800
commit2dd02608735cf61e78cee97aa63bc80417d1652e (patch)
tree321c9b3b4f76ed8c7d61bc1f10ffa8bc765f8c86 /meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb
parent97c41dcd671efb1497a0128a886ad949b4ceb58d (diff)
downloadmeta-openembedded-2dd02608735cf61e78cee97aa63bc80417d1652e.tar.gz
python3-constantly: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb b/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb
index 3f667540d9..ad24f6de6d 100644
--- a/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb
@@ -1,2 +1,11 @@
-inherit setuptools3
-require python-constantly.inc
+DESCRIPTION = "Symbolic constants in Python"
+HOMEPAGE = "https://github.com/twisted/constantly"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e393e4ddd223e3a74982efa784f89fd7"
+
+SRC_URI[md5sum] = "f0762f083d83039758e53f8cf0086eef"
+SRC_URI[sha256sum] = "586372eb92059873e29eba4f9dec8381541b4d3834660707faf8ba59146dfc35"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-json"