aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-18 18:34:43 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-19 14:04:20 -0700
commit8023f69bf95ec3adeb9911048662a4c829c9cdd0 (patch)
treee283d7f42c38930af5b2535d7417c078165d2098 /meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb
parent75d08193f05f1022fdb9e71870353f218ec2f9f9 (diff)
downloadmeta-openembedded-8023f69bf95ec3adeb9911048662a4c829c9cdd0.tar.gz
python3-djangorestframework: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb b/meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb
index 9ed6d17266..438a5e19a2 100644
--- a/meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb
@@ -1,2 +1,16 @@
-require python-djangorestframework.inc
-inherit setuptools3 \ No newline at end of file
+SUMMARY = "djangorestframework"
+DESCRIPTION = "pip3 install djangorestframework"
+HOMEPAGE = "https://pypi.python.org/pypi/djangorestframework"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=7879a5a716147a784f7e524c9cf103c1"
+
+SRC_URI[md5sum] = "0d481bf8dbb87bb927b46798edc1a9bd"
+SRC_URI[sha256sum] = "607865b0bb1598b153793892101d881466bd5a991de12bd6229abb18b1c86136"
+PYPI_PACKAGE = "djangorestframework"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-django \
+"