aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-08-27 13:39:22 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-30 08:10:12 -0700
commit7ff05d34db72c63fc287a299487421d70e6134a2 (patch)
treea72d44e378d98add8e4b9a0d0a7934156ffa1f13 /meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb
parenta01340c1767c99e558b2a43263ec966df57214d5 (diff)
downloadmeta-openembedded-7ff05d34db72c63fc287a299487421d70e6134a2.tar.gz
python3-gevent: upgrade 21.1.2 -> 21.8.0
21.8.0 (2021-08-05) =================== Features -------- - Update the embedded c-ares from 1.16.1 to 1.17.1. See :issue:`1758`. - Add support for Python 3.10rc1 and newer. As part of this, the minimum required greenlet version was increased to 1.1.0 (on CPython), and the minimum version of Cython needed to build gevent from a source checkout is 3.0a9. Note that the dnspython resolver is not available on Python 3.10. See :issue:`1790`. - Update from Cython 3.0a6 to 3.0a9. See :issue:`1801`. Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb b/meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb
new file mode 100644
index 0000000000..74ae6cf69d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb
@@ -0,0 +1,33 @@
+SUMMARY = "A coroutine-based Python networking library"
+DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \
+a high-level synchronous API on top of the libevent event loop."
+HOMEPAGE = "http://www.gevent.org"
+LICENSE = "MIT & Python-2.0 & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \
+ file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \
+ file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \
+ "
+DEPENDS += "libevent"
+DEPENDS += "${PYTHON_PN}-greenlet"
+RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \
+ ${PYTHON_PN}-mime \
+ ${PYTHON_PN}-pprint \
+ "
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/python-gevent:"
+
+SRC_URI:append = " \
+ file://libev-conf.patch;patch=1;pnum=1 \
+"
+
+SRC_URI[sha256sum] = "43e93e1a4738c922a2416baf33f0afb0a20b22d3dba886720bc037cd02a98575"
+
+# The python-gevent has no autoreconf ability
+# and the logic for detecting a cross compile is flawed
+# so always force a cross compile
+do_configure:append() {
+ sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/libev/configure
+ sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/c-ares/configure
+}
+
+inherit pypi setuptools3