aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-incremental_21.3.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-08 18:18:10 +0200
committerKhem Raj <raj.khem@gmail.com>2021-03-11 19:59:04 -0800
commit4cd1e3e4a33df23742692fc63d98b3d5e258aea0 (patch)
treefebf9c0d278d8d68e814d7937591ab20e8a85ff6 /meta-python/recipes-devtools/python/python3-incremental_21.3.0.bb
parent01fc700f27e1ef4c5b5e31c38efcdfaa707f4463 (diff)
downloadmeta-openembedded-4cd1e3e4a33df23742692fc63d98b3d5e258aea0.tar.gz
python3-incremental: Upgrade 17.5.0 -> 21.3.0
Upgrade to release 21.3.0: - The output of incremental is now compatible with Black - Incremental now properly supports PEP 440-compliant dev, rc, post suffixes - Incremental now properly supports PEP 440-compliant post releases Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-incremental_21.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-incremental_21.3.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-incremental_21.3.0.bb b/meta-python/recipes-devtools/python/python3-incremental_21.3.0.bb
new file mode 100644
index 0000000000..ff8fab31f4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-incremental_21.3.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Incremental is a small library that versions your Python projects"
+HOMEPAGE = "https://github.com/twisted/incremental"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
+
+SRC_URI[sha256sum] = "02f5de5aff48f6b9f665d99d48bfc7ec03b6e3943210de7cfc88856d755d6f57"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-twisted \
+ ${PYTHON_PN}-click \
+"
+
+# -native is needed to build python[3]-twisted, however, we need to take steps to
+# prevent a circular dependency. The build apparently does not use the part of
+# python-incremental which uses python-twisted, so this hack is OK.
+RDEPENDS_${PYTHON_PN}-incremental-native_remove = "${PYTHON_PN}-twisted-native"
+BBCLASSEXTEND = "native"