aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-03-17 19:13:16 +0000
committerTrevor Gamblin <trevor.gamblin@windriver.com>2022-03-21 09:57:28 -0400
commit1e48da0f1e0e4382d07dcde94567cff8f8d4f7ab (patch)
tree20252b7c52da87a82af097ac6c75ce3c0d9064ee /meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
parent9b4c80a4102a56eefe466be0a3662340b5e3d248 (diff)
downloadmeta-openembedded-1e48da0f1e0e4382d07dcde94567cff8f8d4f7ab.tar.gz
python3-lz4: use system lz4 library
Instead of using the copy of lz4 that is embedded in the python3-lz4 source code, use the system lz4 library. python3-lz4: PKGSIZE changed from 718282 to 165043 (-77%) python3-lz4: RDEPENDS: added "lz4 (['>= 1.9.3'])" Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb b/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
index 42f0743bea..75472d327e 100644
--- a/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
@@ -4,12 +4,13 @@ LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=6231efa4dd4811e62407314d90a57573"
DEPENDS += " \
+ lz4 \
${PYTHON_PN}-setuptools-scm-native \
${PYTHON_PN}-pkgconfig-native \
"
SRC_URI[sha256sum] = "57c5dfd3b7dae833b0d2b2c1aafd7f9d0dfcab40683d183d010c67c9fd1beca3"
-inherit pypi python_setuptools_build_meta
+inherit pkgconfig pypi python_setuptools_build_meta
BBCLASSEXTEND = "native nativesdk"