aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-03-18 12:02:38 +0000
committerTrevor Gamblin <trevor.gamblin@windriver.com>2022-03-21 09:57:28 -0400
commitf42408bafc89aede4b0605aa9a2ccd9b05eada7e (patch)
treed29bab9661cfcfe1d7ea382ed70107d9f24f2dd6 /meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
parent1adfa91ddb2471aad83682ab28c8d2ecd26fdd96 (diff)
downloadmeta-openembedded-f42408bafc89aede4b0605aa9a2ccd9b05eada7e.tar.gz
python3-lz4: add ptest
Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb b/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
index 75472d327e..ef5b006272 100644
--- a/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
@@ -9,8 +9,18 @@ DEPENDS += " \
${PYTHON_PN}-pkgconfig-native \
"
+SRC_URI += "file://run-ptest"
+
SRC_URI[sha256sum] = "57c5dfd3b7dae833b0d2b2c1aafd7f9d0dfcab40683d183d010c67c9fd1beca3"
-inherit pkgconfig pypi python_setuptools_build_meta
+inherit pkgconfig pypi python_setuptools_build_meta ptest
+
+RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest ${PYTHON_PN}-multiprocessing ${PYTHON_PN}-psutil"
+
+do_install_ptest() {
+ cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
+ # The stream API is experimental and not enabled yet, so don't ship the test suite
+ rm -rf ${D}${PTEST_PATH}/tests/stream
+}
BBCLASSEXTEND = "native nativesdk"