aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-multidict_6.0.2.bb
diff options
context:
space:
mode:
authorXu Huan <xuhuan.fnst@fujitsu.com>2022-01-27 10:06:51 +0800
committerKhem Raj <raj.khem@gmail.com>2022-01-31 08:15:17 -0800
commit5b33cef51e1871ad3eb5dec294c4b0a9586722fd (patch)
tree6c8dcf25474842db751558fbb8dddf6723c64c2b /meta-python/recipes-devtools/python/python3-multidict_6.0.2.bb
parent32d661fd01e21aec33a104bc2ff00f54d47d0650 (diff)
downloadmeta-openembedded-5b33cef51e1871ad3eb5dec294c4b0a9586722fd.tar.gz
python3-multidict: upgrade 5.2.0 -> 6.0.2
changelog: Bugfixes Revert :issue:`644` restore type annotations to as-of 5.2.0 version. (:issue:`688`) Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-multidict_6.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict_6.0.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict_6.0.2.bb b/meta-python/recipes-devtools/python/python3-multidict_6.0.2.bb
new file mode 100644
index 0000000000..b0e111d643
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-multidict_6.0.2.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
+HOMEPAGE = "https://github.com/aio-libs/multidict/"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=84c63e2bcd84e619d249af5181e2147f"
+
+SRC_URI[sha256sum] = "5ff3bd75f38e4c43f1f470f2df7a4d430b821c4ce22be384e1459cb57d6bb013"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"