aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-openpyxl_3.0.9.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-10-12 13:29:41 +0800
committerKhem Raj <raj.khem@gmail.com>2021-10-14 07:15:37 -0700
commit18f4c0b5e8aba27edd5758b7dce5e632ce924aee (patch)
tree9b21c7612692fb8a89f7d4931bbe31ac3b4e6c30 /meta-python/recipes-devtools/python/python3-openpyxl_3.0.9.bb
parenta7c5d615089b25b11d8166030a4de846c6fdce99 (diff)
downloadmeta-openembedded-18f4c0b5e8aba27edd5758b7dce5e632ce924aee.tar.gz
python3-openpyxl: upgrade 3.0.8 -> 3.0.9
Bugfixes Ignore blank ignored in existing Data Validations Add support for cell protection for merged cell ranges Timezone-aware datetimes raise an Exception Improved normalisation of chart series Catch OverflowError for out of range datetimes Alignment.relativeIndent can be negative Incorrect default value groupBy attribute Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-openpyxl_3.0.9.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-openpyxl_3.0.9.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-openpyxl_3.0.9.bb b/meta-python/recipes-devtools/python/python3-openpyxl_3.0.9.bb
new file mode 100644
index 0000000000..4dfd4490ab
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-openpyxl_3.0.9.bb
@@ -0,0 +1,23 @@
+SUMMARY = "openpyxl is a Python library to read/write Excel 2010 xlsx/xlsm/xltx/xltm files"
+DESCRIPTION = "It was born from lack of existing library to read/write natively \
+from Python the Office Open XML format. All kudos to the PHPExcel team as openpyxl \
+was initially based on PHPExcel."
+
+HOMEPAGE = "http://www.python-excel.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "40f568b9829bf9e446acfffce30250ac1fa39035124d55fc024025c41481c90f"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-jdcal \
+ ${PYTHON_PN}-et-xmlfile \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-xml \
+"