aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-03 13:08:36 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-05 18:42:15 -0700
commitf1919b7e1c5ce6562715b801f6051721af6db259 (patch)
treebe5252c11606fc959b6de12af58e833460c84893 /meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb
parent7196961f5e7cd55b4b17af477977c629af24fc67 (diff)
downloadmeta-openembedded-f1919b7e1c5ce6562715b801f6051721af6db259.tar.gz
python-pyaudio: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb b/meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb
index abb01bf691..b2c890659e 100644
--- a/meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb
+++ b/meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb
@@ -1,2 +1,15 @@
-require python-pyaudio.inc
+SUMMARY = "PyAudio provides Python bindings for PortAudio, the cross-platform audio I/O library"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README;md5=288793c2b9b05bd67abbd2a8f5d144f7"
+
+PYPI_PACKAGE = "PyAudio"
+
+SRC_URI[md5sum] = "7e4c88139284033f67b4336c74eda3b8"
+SRC_URI[sha256sum] = "93bfde30e0b64e63a46f2fd77e85c41fd51182a4a3413d9edfaf9ffaa26efb74"
+
inherit pypi setuptools3
+
+DEPENDS += "portaudio-v19"
+
+RDEPENDS_${PN} += "portaudio-v19"