aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pydbus-manager_git.bb
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2021-02-10 15:21:26 +0100
committerKhem Raj <raj.khem@gmail.com>2021-02-16 08:51:01 -0800
commitb8d6d062e1b242b517be30189f69d2c273e4e4d7 (patch)
tree4ed6444374089813626a009f4b0caf1339853229 /meta-python/recipes-devtools/python/python3-pydbus-manager_git.bb
parent558d1e25a1749f2d87f8ec2a80c546b09f5b6398 (diff)
downloadmeta-openembedded-b8d6d062e1b242b517be30189f69d2c273e4e4d7.tar.gz
pydbus-manager: new package
pydbus is a popular (and probably the most 'pythonic') implementation of DBus for python but unfortunately it doesn't implement the ObjectManager interface. This project is an extension providing this functionality. The reason for having this as a separate project is simple: pydbus seems to no longer be actively maintained so it's hard to make it part of the original codebase. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pydbus-manager_git.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pydbus-manager_git.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pydbus-manager_git.bb b/meta-python/recipes-devtools/python/python3-pydbus-manager_git.bb
new file mode 100644
index 0000000000..ae9e42160f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pydbus-manager_git.bb
@@ -0,0 +1,13 @@
+SUMMARY = "DBus.ObjectManager implementation for pydbus"
+AUTHOR = "Sébastien Corne"
+
+LICENSE = "WTFPL"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0fd5bb1dae91ba145745db55870be6a7"
+
+inherit setuptools3
+
+SRC_URI = "git://github.com/seebz/pydbus-manager.git"
+SRCREV = "6b576b969cbda50521dca62a7df929167207f9fc"
+PV = "git${SRCPV}"
+
+S = "${WORKDIR}/git"