aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-requests_2.26.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-07-16 12:21:16 +0300
committerKhem Raj <raj.khem@gmail.com>2021-07-20 09:27:56 -0700
commitbb00cfa7f7cdaffe397881f6c3f7e30d490a693d (patch)
treefe626aef9cde31c04014b73fbf0e7ace98240e89 /meta-python/recipes-devtools/python/python3-requests_2.26.0.bb
parent9a9a39b55987c75ed598694a79d13daf318ca20f (diff)
downloadmeta-openembedded-bb00cfa7f7cdaffe397881f6c3f7e30d490a693d.tar.gz
python3-requests: Upgrade 2.25.1 -> 2.26.0
Upgrade to release 2.26.0: - Requests now supports Brotli compression, if either the `brotli` or `brotlicffi` package is installed - `Session.send` now correctly resolves proxy configurations from both the Session and Request. Behavior now matches `Session.request`. - Fixed a race condition in zip extraction when using Requests in parallel from zip archive. - Requests now supports `idna` 3.x on Python 3. `idna` 2.x will continue to be used on Python 2 installations Drop setup.py-Support-idna-version-3.1.patch because the issue with idna version has been solved in the upstream for Python 3. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests_2.26.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.26.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.26.0.bb b/meta-python/recipes-devtools/python/python3-requests_2.26.0.bb
new file mode 100644
index 0000000000..95e6e1a6b6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests_2.26.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Python HTTP for Humans."
+HOMEPAGE = "http://python-requests.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRC_URI[sha256sum] = "b8aa58f8cf793ffd8782d3d8cb19e66ef36f7aba4353eec859e74678b01b07a7"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-ndg-httpsclient \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-pysocks \
+ ${PYTHON_PN}-urllib3 \
+ ${PYTHON_PN}-chardet \
+ ${PYTHON_PN}-idna \
+"
+
+CVE_PRODUCT = "requests"
+
+BBCLASSEXTEND = "native nativesdk"