aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-03-10 13:25:23 +0000
committerTrevor Gamblin <trevor.gamblin@windriver.com>2022-03-11 08:48:38 -0500
commitff7312f0486df1b5fd9f7eee0ae62fbc831e39d8 (patch)
tree45abea48a254d30c040cc90f6bf9f7290c4cf378 /meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
parent935dd6efa858d551420dd41829d7e9b621664c00 (diff)
downloadmeta-openembedded-ff7312f0486df1b5fd9f7eee0ae62fbc831e39d8.tar.gz
meta-python: migrate away from setuptool3 where possible
Many recipes are currently building with setuptools3 but can use a more modern tool: typically setuptools_build_meta but ordered-set can use flit_core and pyrad can use poetry_core. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
index 8ad6acc875..279c2562fe 100644
--- a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
+++ b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=dc9277482effe59b734b004cbcc1fee7"
SRC_URI[sha256sum] = "3e0be507486d4e21cf9d08847c7e57dd61a1603950399985f7c5a0be7fd33e36"
-inherit pypi setuptools3 ptest
+inherit pypi setuptools_build_meta ptest
BBCLASSEXTEND = "native nativesdk"
@@ -21,10 +21,6 @@ RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
-do_configure:prepend() {
- sed -i -e "/use_2to3=True,/d" ${S}/setup.py
-}
-
do_install_ptest() {
cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/
}