aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-simplejson_3.17.6.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-11-19 12:27:39 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-20 12:07:09 -0800
commit113e6e642cb1c7ea8e79601b61d937f9257eaec4 (patch)
tree3ffcc207a53a69947cf026790292377f2a40fd72 /meta-python/recipes-devtools/python/python3-simplejson_3.17.6.bb
parent2300858be128e645dfdfa6368e81755c4898b3a1 (diff)
downloadmeta-openembedded-113e6e642cb1c7ea8e79601b61d937f9257eaec4.tar.gz
python3-simplejson: Upgrade 3.17.5 -> 3.17.6
Upgrade to release 3.17.6: - Declare support for Python 3.10 and add wheels Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-simplejson_3.17.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-simplejson_3.17.6.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simplejson_3.17.6.bb b/meta-python/recipes-devtools/python/python3-simplejson_3.17.6.bb
new file mode 100644
index 0000000000..b836f97fe0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-simplejson_3.17.6.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e"
+
+SRC_URI[sha256sum] = "cf98038d2abf63a1ada5730e91e84c642ba6c225b0198c3684151b1f80c5f8a6"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+"
+
+PACKAGES =+ "${PN}-tests"
+RDEPENDS:${PN}-tests = "${PN} ${PYTHON_PN}-unittest"
+FILES:${PN}-tests+= " \
+ ${PYTHON_SITEPACKAGES_DIR}/simplejson/tests \
+ ${PYTHON_SITEPACKAGES_DIR}/simplejson/tool.py* \
+"
+
+BBCLASSEXTEND = "native nativesdk"