aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-05-24 13:11:47 +0100
committerKhem Raj <raj.khem@gmail.com>2022-05-29 06:39:14 -0700
commitfa8929b9b6c7246f65c5e3f7b0979c39a65bd314 (patch)
tree7e95505ee917330a913644778337b300eb4bad80 /meta-python/recipes-devtools
parenta2790f4316d8e82299723c27526d866f5f931ca7 (diff)
downloadmeta-openembedded-fa8929b9b6c7246f65c5e3f7b0979c39a65bd314.tar.gz
python3-setuptools-scm-git-archive: add new recipe
Some Python packages use this at build time. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-setuptools-scm-git-archive_1.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-setuptools-scm-git-archive_1.1.bb b/meta-python/recipes-devtools/python/python3-setuptools-scm-git-archive_1.1.bb
new file mode 100644
index 0000000000..472c4eb1c8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-setuptools-scm-git-archive_1.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "setuptools_scm plugin for git archives"
+HOMEPAGE = "https://pypi.org/project/setuptools-scm-git-archive/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=838c366f69b72c5df05c96dff79b35f2"
+
+SRC_URI[sha256sum] = "6026f61089b73fa1b5ee737e95314f41cb512609b393530385ed281d0b46c062"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "setuptools_scm_git_archive"
+PYPI_SRC_URI = "https://files.pythonhosted.org/packages/7e/2c/0c15b29a1b5940250bfdc4a4f53272e35cd7cf8a34159291b6b4ec9eb291/${PYPI_ARCHIVE_NAME}"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"