aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-20 19:42:35 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-24 07:36:49 -0700
commit6818fcdbaec46021b423d20c946169eadf41d4e3 (patch)
treeab44b4f7a60c564ada1de68e816992d6e8051b48 /meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb
parent9bd205e4171f3fb72da713dbdeb50f6a763bff26 (diff)
downloadmeta-openembedded-6818fcdbaec46021b423d20c946169eadf41d4e3.tar.gz
python3-pywbem: Upgrade 1.1.3 -> 1.2.0
Upgrade to release 1.2.0 with bug fixes and enhancements: - Finalized the pywbem mock support - Logging: Added a value 'off' for the log destination in the pywbem.configure_logging() function that disables logging - Improved exception handling during the parsing of CIM-XML responses received from a WBEM server - Reduced memory consumption of CIM objects and CIM types by defining their attributes to use Python slots - Reduced memory consumption of CIM objects by using lazy initialization of dictionary-type attributes - Unsupported versions for CIM infrastructure, DTD or protocol version returned in CIM-XML responses from WBEM servers are now raised as new exceptions pywbem - In the makefile, added an ignore list for issues reported by safety along with the reasons why each issue is ignored - Improvements in the log messages of the MOFCompiler class - Added a conn_close() method to the pywbem.MOFCompiler class that closes the underlying connection - Added 'make perftest' to run performance tests Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb')
-rw-r--r--meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb b/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb
new file mode 100644
index 0000000000..988dae1335
--- /dev/null
+++ b/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb
@@ -0,0 +1,51 @@
+SUMMARY = "Python WBEM Client and Provider Interface"
+DESCRIPTION = "\
+A Python library for making CIM (Common Information Model) operations over \
+HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \
+WBEM client should be easy to use and not necessarily require a large amount \
+of programming knowledge. It is suitable for a large range of tasks from \
+simply poking around to writing web and GUI applications. \
+\
+WBEM, or Web Based Enterprise Management is a manageability protocol, like \
+SNMP, standardised by the Distributed Management Task Force (DMTF) available \
+at http://www.dmtf.org/standards/wbem. \
+\
+It also provides a Python provider interface, and is the fastest and easiest \
+way to write providers on the planet."
+HOMEPAGE = "http://pywbem.github.io"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
+
+SRC_URI[sha256sum] = "8ef48185e0adbaeb9bd5181c4c5de951f6d58d54e2e1d7e87a9834e10eabe957"
+
+inherit pypi setuptools3 update-alternatives
+
+DEPENDS += " \
+ ${PYTHON_PN}-ply-native \
+ ${PYTHON_PN}-pyyaml-native \
+ ${PYTHON_PN}-six-native \
+ ${PYTHON_PN}-wheel-native \
+"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-ply \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-unixadmin \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-nocasedict \
+ ${PYTHON_PN}-nocaselist \
+ ${PYTHON_PN}-yamlloader \
+"
+
+ALTERNATIVE_${PN} = "mof_compiler"
+ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
+
+ALTERNATIVE_PRIORITY = "60"
+
+BBCLASSEXTEND = "native"