aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-02 12:28:54 -0800
committerKhem Raj <raj.khem@gmail.com>2022-03-03 08:48:07 -0800
commit992da9e0aadd45d95b5af9daf7f0f0200e390744 (patch)
tree586ada11848290e0a69ee9e1fd503ccd64efa42b /meta-python/recipes-extended
parentb08d16afa2f5043ccbe5b8f8a20c6b22300b521e (diff)
downloadmeta-openembedded-992da9e0aadd45d95b5af9daf7f0f0200e390744.tar.gz
python3-blivetgui: Upgrade to 2.3.0
Backport a fix to migrate to use setuptools instead of distutils Changes in this release are [1] [1] https://github.com/storaged-project/blivet-gui/releases/tag/2.3.0-1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch30
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb (renamed from meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb)6
2 files changed, 34 insertions, 2 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch
new file mode 100644
index 0000000000..c88912bfa0
--- /dev/null
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch
@@ -0,0 +1,30 @@
+From 54014061be2fed20d6c35aba9719ea70a9fea9ea Mon Sep 17 00:00:00 2001
+From: Vojtech Trefny <vtrefny@redhat.com>
+Date: Wed, 1 Sep 2021 08:59:19 +0200
+Subject: [PATCH] Use setuptools instead of distutils in setup.py
+
+The distutils module is deprecated and will be removed in Python
+3.12.
+
+Upstream-Status: Backport [https://github.com/kraj/blivet-gui/commit/54014061be2fed20d6c35aba9719ea70a9fea9ea]
+---
+ setup.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index aa8ef57..77849a1 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,7 +1,7 @@
+ from __future__ import print_function
+
+-from distutils.core import setup
+-from distutils.command.sdist import sdist
++from setuptools import setup
++from setuptools.command.sdist import sdist
+ import glob
+ import sys
+
+--
+2.35.1
+
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb
index 632b313a86..9522770eff 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb
@@ -8,8 +8,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
S = "${WORKDIR}/git"
B = "${S}"
-SRCREV = "adb6bd69fb3cfa709265db66ddcee04c0b5e070f"
-SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=master;protocol=https"
+SRCREV = "42512ee48494cee71febf04078d9774f0146a085"
+SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=master;protocol=https \
+ file://0001-Use-setuptools-instead-of-distutils-in-setup.py.patch \
+ "
inherit features_check
REQUIRED_DISTRO_FEATURES = "x11 systemd"