aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-12 10:41:49 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-14 08:17:25 -0700
commite5b828d01b4f5d748e92614c5adaed551e1e220a (patch)
tree015299f6cae620b9a3860f8d18a66351e4b548d0 /meta-python
parentba30fa8a64a25620487d49d51e1eb92b4b0be14b (diff)
downloadmeta-openembedded-e5b828d01b4f5d748e92614c5adaed551e1e220a.tar.gz
python3-eth-abi: new package
Add a recipe for eth-abi: utilities for working with Ethereum ABI definitions. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-abi_3.0.0.bb18
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 41e30fad03..db3f8516ac 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -110,6 +110,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-email-validator \
python3-engineio \
python3-et-xmlfile \
+ python3-eth-abi \
python3-eth-hash \
python3-eth-keyfile \
python3-eth-keys \
diff --git a/meta-python/recipes-devtools/python/python3-eth-abi_3.0.0.bb b/meta-python/recipes-devtools/python/python3-eth-abi_3.0.0.bb
new file mode 100644
index 0000000000..e1f220af98
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-abi_3.0.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Python utilities for working with Ethereum ABI definitions, especially encoding and decoding."
+HOMEPAGE = "https://github.com/ethereum/eth-abi"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bf9691ead96f1163622689e47ce3f366"
+
+SRC_URI[sha256sum] = "31578b179cf9430c21ac32a4e5f401c14b6e2cc1fd64ca3587cd354068217804"
+
+PYPI_PACKAGE = "eth_abi"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-eth-typing \
+ python3-eth-utils \
+ python3-parsimonious \
+ python3-setuptools \
+"