aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb')
-rw-r--r--meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb b/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
index 0086551f62..5dc3ea6632 100644
--- a/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
+++ b/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
@@ -8,18 +8,15 @@ inherit pkgconfig
DEPENDS += "fuse"
RDEPENDS:${PN} += "fuse"
-SRC_URI += "https://astuteinternet.dl.sourceforge.net/project/httpfs/httpfs2/httpfs2-${PV}.tar.gz"
+SRC_URI += "${SOURCEFORGE_MIRROR}/project/httpfs/httpfs2/httpfs2-${PV}.tar.gz"
SRC_URI[sha256sum] = "01cb4bb38deb344f540da6f1464dc7edbdeb51213ad810b8c9c282c1e17e0fc1"
S = "${WORKDIR}/httpfs2-${PV}"
do_compile() {
- cd ${S}
- oe_runmake httpfs2
+ oe_runmake -C ${S} httpfs2
}
do_install() {
- cd ${S}
- install -d ${D}${bindir}
- install -m 0755 httpfs2 ${D}${bindir}
+ install -Dm 0755 ${S}/httpfs2 ${D}${bindir}/httpfs2
}