aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-shell
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-shell')
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell-extensions_46.0.bb (renamed from meta-gnome/recipes-gnome/gnome-shell/gnome-shell-extensions_41.0.bb)11
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch52
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.0.bb (renamed from meta-gnome/recipes-gnome/gnome-shell/gnome-shell_41.0.bb)42
3 files changed, 64 insertions, 41 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell-extensions_41.0.bb b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell-extensions_46.0.bb
index dc9502dc5f..eff5fecffe 100644
--- a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell-extensions_41.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell-extensions_46.0.bb
@@ -1,18 +1,12 @@
SUMMARY = "GNOME Shell Extensions"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=4cb3a392cbf81a9e685ec13b88c4c101"
-GNOMEBASEBUILDCLASS = "meson"
-
inherit gnomebase gettext gsettings features_check
REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam gobject-introspection-data"
-SRC_URI[archive.sha256sum] = "d84faac1448b38f975d9c19490c5928afc5c5a2c49dd7e7f81af690f9466fc68"
-
-DEPENDS += " \
- sassc-native \
-"
+SRC_URI[archive.sha256sum] = "d8138f88cd92df9f932309149c236fbdd77c1bc095445036ab7eb0ecda53c01a"
EXTRA_OEMESON += " \
-Dextension_set=all \
@@ -24,5 +18,6 @@ RDEPENDS:${PN} += "gnome-shell"
FILES:${PN} += " \
${datadir}/gnome-shell \
${datadir}/gnome-session \
+ ${datadir}/wayland-sessions \
${datadir}/xsessions \
"
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch
index 15e3c8c647..8ef0da16fe 100644
--- a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch
@@ -1,4 +1,4 @@
-From 3bf597b16e23cd2ce0ee3b05c23b46add5e26cd4 Mon Sep 17 00:00:00 2001
+From e9835f650d70bf22ad0e5d8c2179aa01b2d18955 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Thu, 28 Oct 2021 18:57:24 +0200
Subject: [PATCH] Introduce options 'gjs_path' to optionally set path to gjs
@@ -6,6 +6,21 @@ MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
Upstream-Status: Pending
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
@@ -19,25 +34,25 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
6 files changed, 25 insertions(+), 4 deletions(-)
diff --git a/js/dbusServices/meson.build b/js/dbusServices/meson.build
-index 68e8bd12d..16efaebe5 100644
+index 48b7f89..700b590 100644
--- a/js/dbusServices/meson.build
+++ b/js/dbusServices/meson.build
-@@ -27,7 +27,7 @@ foreach service, dir : dbus_services
+@@ -22,7 +22,7 @@ foreach service, dir : dbus_services
serviceconf = configuration_data()
serviceconf.set('service', service)
-- serviceconf.set('gjs', gjs.path())
+- serviceconf.set('gjs', gjs.full_path())
+ serviceconf.set('gjs', gjs)
serviceconf.set('pkgdatadir', pkgdatadir)
configure_file(
diff --git a/meson.build b/meson.build
-index d4583ecf2..3448c6312 100644
+index a6d83b1..2c612a8 100644
--- a/meson.build
+++ b/meson.build
-@@ -138,7 +138,11 @@ endif
+@@ -134,7 +134,11 @@ endif
- mutter_typelibdir = mutter_dep.get_pkgconfig_variable('typelibdir')
+ mutter_typelibdir = mutter_dep.get_variable('typelibdir')
python = find_program('python3')
-gjs = find_program('gjs')
+if get_option('gjs_path') == ''
@@ -49,12 +64,12 @@ index d4583ecf2..3448c6312 100644
cc = meson.get_compiler('c')
diff --git a/meson_options.txt b/meson_options.txt
-index f0f2ecf6c..a45f2e453 100644
+index 6e83d92..1bf0ecb 100644
--- a/meson_options.txt
+++ b/meson_options.txt
-@@ -45,3 +45,9 @@ option('soup2',
+@@ -45,3 +45,9 @@ option('systemd',
value: true,
- description: 'Use Soup 2.4 instead of Soup 3. Must be in sync with libgweather'
+ description: 'Enable systemd integration'
)
+
+option('gjs_path',
@@ -63,24 +78,24 @@ index f0f2ecf6c..a45f2e453 100644
+ description: 'Instead of searching gjs executable, configure path'
+)
diff --git a/subprojects/extensions-app/js/meson.build b/subprojects/extensions-app/js/meson.build
-index f311db6e0..8f7bba4e4 100644
+index c9a67f8..91ae887 100644
--- a/subprojects/extensions-app/js/meson.build
+++ b/subprojects/extensions-app/js/meson.build
@@ -9,7 +9,7 @@ endif
launcherconf.set('prefix', prefix)
launcherconf.set('libdir', libdir)
launcherconf.set('pkgdatadir', pkgdatadir)
--launcherconf.set('gjs', gjs.path())
+-launcherconf.set('gjs', gjs.full_path())
+launcherconf.set('gjs', gjs)
configure_file(
input: prgname + '.in',
diff --git a/subprojects/extensions-app/meson.build b/subprojects/extensions-app/meson.build
-index f9ccfc24d..bdf118975 100644
+index 45f391b..d581408 100644
--- a/subprojects/extensions-app/meson.build
+++ b/subprojects/extensions-app/meson.build
-@@ -44,7 +44,12 @@ localedir = join_paths(datadir, 'locale')
- metainfodir = join_paths(datadir, 'metainfo')
+@@ -47,7 +47,12 @@ metainfodir = join_paths(datadir, 'metainfo')
+ schemadir = join_paths(datadir, 'glib-2.0', 'schemas')
servicedir = join_paths(datadir, 'dbus-1', 'services')
-gjs = find_program('gjs')
@@ -91,10 +106,10 @@ index f9ccfc24d..bdf118975 100644
+endif
+
appstream_util = find_program('appstream-util', required: false)
+ appstreamcli = find_program('appstreamcli', required: false)
desktop_file_validate = find_program('desktop-file-validate', required: false)
-
diff --git a/subprojects/extensions-app/meson_options.txt b/subprojects/extensions-app/meson_options.txt
-index ca2eb4115..2787785bf 100644
+index ca2eb41..2787785 100644
--- a/subprojects/extensions-app/meson_options.txt
+++ b/subprojects/extensions-app/meson_options.txt
@@ -10,3 +10,9 @@ option('profile',
@@ -107,6 +122,3 @@ index ca2eb4115..2787785bf 100644
+ value: '',
+ description: 'Instead of searching gjs executable, configure path'
+)
---
-2.31.1
-
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_41.0.bb b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.0.bb
index 8378e94782..907cfdf678 100644
--- a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_41.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.0.bb
@@ -1,41 +1,43 @@
SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-GNOMEBASEBUILDCLASS = "meson"
-
-inherit gnomebase gsettings gettext gobject-introspection features_check bash-completion
-
-REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
DEPENDS = " \
libxml2-native \
- sassc-native \
gtk4 \
mutter \
evolution-data-server \
gcr \
+ geocode-glib \
gjs \
gnome-autoar \
+ gnome-desktop \
polkit \
- libcroco \
- startup-notification \
+ pipewire \
+ libsoup-3.0 \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', 'startup-notification', d)} \
ibus \
gsettings-desktop-schemas \
"
+inherit gnomebase gsettings gettext gobject-introspection gtk-icon-cache features_check bash-completion
+
+REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
+
+GTKIC_VERSION = "4"
GTKDOC_MESON_OPTION = "gtk_doc"
GIR_MESON_OPTION = ""
# gobject-introspection is mandatory and cannot be configured
REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
-SRC_URI[archive.sha256sum] = "52f971e85140e5de74b9369ef6656e49ce95af1f232fc1e0df1f046129ab4f65"
+SRC_URI[archive.sha256sum] = "6bc41340b6de05774e97cfe20feba86e2b3cc9c8139118f24bd84ac63e82b53e"
SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch"
PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
-PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false, networkmanager"
+PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false,networkmanager libsecret,networkmanager"
PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
EXTRA_OEMESON = " \
@@ -48,7 +50,7 @@ EXTRA_OEMESON = " \
do_install:append() {
# fix shebangs
for tool in `find ${D}${bindir} -name '*-tool'`; do
- sed -i 's:#!${PYTHON}:#!${bindir}/${PYTHON_PN}:' $tool
+ sed -i 's:#!${PYTHON}:#!${bindir}/python3:' $tool
done
}
@@ -62,7 +64,21 @@ FILES:${PN} += " \
${systemd_user_unitdir} \
"
-RDEPENDS:${PN} += "gsettings-desktop-schemas gdm-base librsvg-gtk ${PN}-gsettings"
+RDEPENDS:${PN} += " \
+ accountsservice \
+ adwaita-icon-theme \
+ adwaita-icon-theme-cursors \
+ gdm-base \
+ gnome-control-center \
+ gnome-backgrounds \
+ gnome-bluetooth \
+ gnome-desktop \
+ gnome-session \
+ gnome-settings-daemon \
+ gnome-shell-gsettings \
+ gsettings-desktop-schemas \
+ librsvg-gtk \
+"
PACKAGES =+ "${PN}-tools ${PN}-gsettings"
FILES:${PN}-tools = "${bindir}/*-tool"