aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/autossh
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/autossh')
-rw-r--r--meta-networking/recipes-connectivity/autossh/autossh_1.4g.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/meta-networking/recipes-connectivity/autossh/autossh_1.4g.bb b/meta-networking/recipes-connectivity/autossh/autossh_1.4g.bb
index 9b69601e7b..de7e2d3e01 100644
--- a/meta-networking/recipes-connectivity/autossh/autossh_1.4g.bb
+++ b/meta-networking/recipes-connectivity/autossh/autossh_1.4g.bb
@@ -1,22 +1,23 @@
DESCRIPTION = "autossh is a program to start a copy of ssh and monitor it, restarting it as necessary should it die or stop passing traffic"
HOMEPAGE = "https://www.harding.motd.ca/autossh/"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://autossh.spec;md5=80a6701134723fd3420e733b46a0eb97"
+LICENSE = "BSD-1-Clause & BSD-4-Clause"
+LIC_FILES_CHKSUM = "file://autossh.c;beginline=7;endline=22;md5=9ae0c9b04856148d77984ef58536732b \
+ file://daemon.h;beginline=7;endline=36;md5=839bb7bf781ff48da4a3fec2a62a1a47"
SRC_URI = "https://www.harding.motd.ca/autossh/${BP}.tgz"
SRC_URI[md5sum] = "2b804bc1bf6d2f2afaa526d02df7c0a2"
SRC_URI[sha256sum] = "5fc3cee3361ca1615af862364c480593171d0c54ec156de79fc421e31ae21277"
-RDEPENDS_${PN} = "ssh"
+RDEPENDS:${PN} = "ssh"
-CFLAGS_prepend = "-I${WORKDIR}/build "
+CFLAGS:prepend = "-I${WORKDIR}/build "
inherit autotools
EXTRA_OECONF="--with-ssh=/usr/bin/ssh"
-do_compile_append() {
+do_compile:append() {
cp ${WORKDIR}/autossh-${PV}/CHANGES ${WORKDIR}/build
cp ${WORKDIR}/autossh-${PV}/README ${WORKDIR}/build
cp ${WORKDIR}/autossh-${PV}/autossh.host ${WORKDIR}/build
@@ -25,6 +26,6 @@ do_compile_append() {
cp ${WORKDIR}/autossh-${PV}/autossh.spec ${WORKDIR}/build
}
-do_install_append() {
+do_install:append() {
rm -rf ${D}${datadir}/examples
}