aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netperf/netperf_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/netperf/netperf_git.bb')
-rw-r--r--meta-networking/recipes-support/netperf/netperf_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-networking/recipes-support/netperf/netperf_git.bb b/meta-networking/recipes-support/netperf/netperf_git.bb
index 4074f0cd07..579a04b86f 100644
--- a/meta-networking/recipes-support/netperf/netperf_git.bb
+++ b/meta-networking/recipes-support/netperf/netperf_git.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.netperf.org/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=e661ab33a2a71ad6652c178dedf8aaa2"
-PV = "2.7.0+git${SRCPV}"
+PV = "2.7.0+git"
SRC_URI = "git://github.com/HewlettPackard/netperf.git;branch=master;protocol=https \
file://cpu_set.patch \
@@ -42,14 +42,14 @@ do_configure:prepend() {
}
do_install() {
- sed -e 's#/usr/sbin/#${sbindir}/#g' -i ${WORKDIR}/init
+ sed -e 's#/usr/sbin/#${sbindir}/#g' -i ${UNPACKDIR}/init
install -d ${D}${sbindir} ${D}${bindir} ${D}${sysconfdir}/init.d ${D}${systemd_system_unitdir}
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- sed -e 's#/usr/sbin/#${sbindir}/#g' ${WORKDIR}/netserver.service > ${D}${systemd_system_unitdir}/netserver.service
+ sed -e 's#/usr/sbin/#${sbindir}/#g' ${UNPACKDIR}/netserver.service > ${D}${systemd_system_unitdir}/netserver.service
fi
install -m 4755 src/netperf ${D}${bindir}
install -m 4755 src/netserver ${D}${sbindir}
- install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/netperf
+ install -m 0755 ${UNPACKDIR}/init ${D}${sysconfdir}/init.d/netperf
# man
install -d ${D}${mandir}/man1/