aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/spice
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/spice')
-rw-r--r--meta-networking/recipes-support/spice/libcacard_2.8.1.bb17
-rw-r--r--meta-networking/recipes-support/spice/phodav_3.0.bb24
-rw-r--r--meta-networking/recipes-support/spice/spice-gtk_0.42.bb68
-rw-r--r--meta-networking/recipes-support/spice/spice-guest-vdagent_0.22.1.bb25
-rw-r--r--meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb21
-rw-r--r--meta-networking/recipes-support/spice/spice-protocol_git.bb28
-rw-r--r--meta-networking/recipes-support/spice/spice/0001-Convert-pthread_t-to-be-numeric.patch59
-rw-r--r--meta-networking/recipes-support/spice/spice/0001-Fix-compile-errors-on-Linux-32bit-system.patch96
-rw-r--r--meta-networking/recipes-support/spice/spice/0001-configure.ac-explicitly-link-to-jpeg-lib.patch48
-rw-r--r--meta-networking/recipes-support/spice/spice_git.bb45
-rw-r--r--meta-networking/recipes-support/spice/usbredir_0.13.0.bb (renamed from meta-networking/recipes-support/spice/usbredir_0.9.0.bb)12
11 files changed, 177 insertions, 266 deletions
diff --git a/meta-networking/recipes-support/spice/libcacard_2.8.1.bb b/meta-networking/recipes-support/spice/libcacard_2.8.1.bb
new file mode 100644
index 0000000000..65f2f80ace
--- /dev/null
+++ b/meta-networking/recipes-support/spice/libcacard_2.8.1.bb
@@ -0,0 +1,17 @@
+SUMMARY = "This library provides emulation of smart cards to a virtual card reader running in a guest virtual machine."
+LICENSE = "LGPL-2.1-or-later"
+LIC_FILES_CHKSUM = "file://COPYING;md5=79ffa0ec772fa86740948cb7327a0cc7"
+
+DEPENDS = "glib-2.0 pcsc-lite nss"
+
+SRCREV = "7b07684ea6698d4885ff2062350ad8798a04de42"
+
+SRC_URI = "git://gitlab.freedesktop.org/spice/libcacard.git;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig
+
+do_configure:prepend() {
+ echo ${PV} > ${S}/.tarball-version
+}
diff --git a/meta-networking/recipes-support/spice/phodav_3.0.bb b/meta-networking/recipes-support/spice/phodav_3.0.bb
new file mode 100644
index 0000000000..08c65eb259
--- /dev/null
+++ b/meta-networking/recipes-support/spice/phodav_3.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "phodav is a WebDav server implementation using libsoup (RFC 4918)."
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = " \
+ glib-2.0 \
+ libsoup \
+"
+
+GTKDOC_MESON_OPTION = 'gtk_doc'
+GTKDOC_MESON_ENABLE_FLAG = 'enabled'
+GTKDOC_MESON_DISABLE_FLAG = 'disabled'
+
+PACKAGECONFIG ??= "avahi"
+PACKAGECONFIG[avahi] = "-Davahi=enabled,-Davahi=disabled,avahi"
+
+inherit pkgconfig gnomebase gettext gtk-doc
+
+EXTRA_OEMESON += "-Dsystemdsystemunitdir=${systemd_system_unitdir}"
+
+SRC_URI = "https://download.gnome.org/sources/phodav/3.0/phodav-${PV}.tar.xz;name=archive"
+SRC_URI[archive.sha256sum] = "392ec2d06d50300dcff1ef269a2a985304e29bce3520002fca29f2edc1d138d1"
+
+FILES:${PN} += "${libdir} ${systemd_system_unitdir}"
diff --git a/meta-networking/recipes-support/spice/spice-gtk_0.42.bb b/meta-networking/recipes-support/spice/spice-gtk_0.42.bb
new file mode 100644
index 0000000000..82ce7067d9
--- /dev/null
+++ b/meta-networking/recipes-support/spice/spice-gtk_0.42.bb
@@ -0,0 +1,68 @@
+SUMMARY = "A Gtk client and libraries for SPICE remote desktop servers."
+HOMEPAGE = "https://spice-space.org"
+LICENSE = "LGPL-2.1-only & BSD-3-Clause & GPL-2.0-only"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=4fbd65380cdd255951079008b364516c \
+ file://subprojects/spice-common/COPYING;md5=4b54a1fd55a448865a0b32d41598759d \
+ file://subprojects/keycodemapdb/LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b \
+ file://subprojects/keycodemapdb/LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe \
+"
+
+SRCREV = "f04479c16f0969fb394ebe74b6eff74e560a42f0"
+
+SRC_URI = "gitsm://gitlab.freedesktop.org/spice/spice-gtk.git;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = " \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland wayland-native wayland-protocols', '', d)} \
+ acl \
+ cyrus-sasl \
+ gstreamer1.0 \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-vaapi \
+ gtk+3 \
+ jpeg \
+ json-glib \
+ libcap-ng \
+ libepoxy \
+ libopus \
+ libusb1 \
+ lz4 \
+ pixman \
+ python3-pyparsing-native \
+ python3-six-native \
+ spice-protocol \
+ usbredir \
+ usbutils \
+ zlib \
+"
+DEPENDS:append:libc-musl = " libucontext"
+
+RDEPENDS:${PN} = "python3-pyparsing python3-six usbids"
+
+inherit meson pkgconfig vala gobject-introspection features_check gtk-doc
+
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+GIR_MESON_ENABLE_FLAG = 'enabled'
+GIR_MESON_DISABLE_FLAG = 'disabled'
+GTKDOC_MESON_OPTION = 'gtk_doc'
+GTKDOC_MESON_ENABLE_FLAG = 'enabled'
+GTKDOC_MESON_DISABLE_FLAG = 'disabled'
+
+do_configure:prepend() {
+ echo ${PV} > ${S}/.tarball-version
+}
+
+PACKAGECONFIG ??= "${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'vapi', '', d)} smartcard"
+PACKAGECONFIG[vapi] = "-Dvapi=enabled,-Dvapi=disabled"
+PACKAGECONFIG[smartcard] = "-Dsmartcard=enabled,-Dsmartcard=disabled,libcacard"
+
+EXTRA_OEMESON = "-Dpie=true -Dusb-ids-path=${datadir}/usb.ids "
+EXTRA_OEMESON:append:libc-musl = " -Dcoroutine=libucontext"
+
+LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', ' -Wl,--undefined-version', '', d)}"
+
+FILES:${PN} += "${datadir}"
diff --git a/meta-networking/recipes-support/spice/spice-guest-vdagent_0.22.1.bb b/meta-networking/recipes-support/spice/spice-guest-vdagent_0.22.1.bb
new file mode 100644
index 0000000000..3af973eed1
--- /dev/null
+++ b/meta-networking/recipes-support/spice/spice-guest-vdagent_0.22.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Spice agent for Linux"
+HOMEPAGE = "https://spice-space.org"
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRCREV = "aa08162f036840d3e33502dc0a836b03b9cec97c"
+
+SRC_URI = "git://gitlab.freedesktop.org/spice/linux/vd_agent.git;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+REQUIRED_DISTRO_FEATURES = "opengl x11"
+
+inherit autotools pkgconfig features_check
+
+DEPENDS = "glib-2.0 alsa-lib gtk4 dbus libdrm spice-protocol libxfixes xrandr xinerama libx11"
+
+EXTRA_OECONF = " \
+ --with-gtk4 \
+ --enable-pie \
+"
+
+FILES:${PN} += "${datadir}"
+
diff --git a/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb b/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb
new file mode 100644
index 0000000000..3c8458baac
--- /dev/null
+++ b/meta-networking/recipes-support/spice/spice-protocol_0.14.4.bb
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2013 Wind River Systems, Inc.
+#
+
+SUMMARY = "Simple Protocol for Independent Computing Environments (protocol definition"
+HOMEPAGE = "https://spice-space.org"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b37311cb5604f3e5cc2fb0fd23527e95"
+
+SRCREV = "6f453a775d87087c6ba59fc180c1a1e466631a47"
+
+SRC_URI = "git://gitlab.freedesktop.org/spice/spice-protocol.git;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig
+
+ALLOW_EMPTY:${PN} = "1"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-networking/recipes-support/spice/spice-protocol_git.bb b/meta-networking/recipes-support/spice/spice-protocol_git.bb
deleted file mode 100644
index ca683bf220..0000000000
--- a/meta-networking/recipes-support/spice/spice-protocol_git.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-#
-# Copyright (C) 2013 Wind River Systems, Inc.
-#
-
-SUMMARY = "Simple Protocol for Independent Computing Environments"
-DESCRIPTION = "SPICE (the Simple Protocol for Independent Computing \
-Environments) is a remote-display system built for virtual \
-environments which allows users to view a computing 'desktop' \
-environment - not only on its computer-server machine, but also from \
-anywhere on the Internet and using a wide variety of machine \
-architectures."
-
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b37311cb5604f3e5cc2fb0fd23527e95"
-
-PV = "0.14.1+git${SRCPV}"
-
-SRCREV = "e0ec178a72aa33e307ee5ac02b63bf336da921a5"
-
-SRC_URI = " \
- git://anongit.freedesktop.org/spice/spice-protocol;branch=master \
-"
-
-S = "${WORKDIR}/git"
-
-inherit autotools gettext pkgconfig
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-networking/recipes-support/spice/spice/0001-Convert-pthread_t-to-be-numeric.patch b/meta-networking/recipes-support/spice/spice/0001-Convert-pthread_t-to-be-numeric.patch
deleted file mode 100644
index e63cbe3b72..0000000000
--- a/meta-networking/recipes-support/spice/spice/0001-Convert-pthread_t-to-be-numeric.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 0726ce6d6f52e135e28f15ca8392568c84909b1d Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 16 Jun 2018 16:21:39 -0700
-Subject: [PATCH] Convert pthread_t to be numeric
-
-typecast pthread_t to unsigned long
-pthread_t is implemented as a struct point in musl and its as per standard
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- server/red-channel.c | 5 +++--
- server/red-client.c | 6 +++---
- 2 files changed, 6 insertions(+), 5 deletions(-)
-
---- a/server/red-channel.c
-+++ b/server/red-channel.c
-@@ -204,7 +204,7 @@ red_channel_constructed(GObject *object)
- {
- RedChannel *self = RED_CHANNEL(object);
-
-- red_channel_debug(self, "thread_id 0x%" G_GSIZE_MODIFIER "x", self->priv->thread_id);
-+ red_channel_debug(self, "thread_id 0x%" G_GSIZE_MODIFIER "x", (unsigned long)self->priv->thread_id);
-
- RedChannelClass *klass = RED_CHANNEL_GET_CLASS(self);
-
-@@ -479,7 +479,8 @@ void red_channel_remove_client(RedChanne
- "pthread_self (0x%" G_GSIZE_MODIFIER "x)."
- "If one of the threads is != io-thread && != vcpu-thread, "
- "this might be a BUG",
-- channel->priv->thread_id, pthread_self());
-+ (unsigned long)channel->priv->thread_id,
-+ (unsigned long)pthread_self());
- }
- spice_return_if_fail(channel);
- link = g_list_find(channel->priv->clients, rcc);
---- a/server/red-client.c
-+++ b/server/red-client.c
-@@ -180,7 +180,7 @@ void red_client_migrate(RedClient *clien
- "pthread_self (0x%" G_GSIZE_MODIFIER "x)."
- "If one of the threads is != io-thread && != vcpu-thread,"
- " this might be a BUG",
-- client->thread_id, pthread_self());
-+ (unsigned long)client->thread_id, (unsigned long)pthread_self());
- }
- FOREACH_CHANNEL_CLIENT(client, rcc) {
- if (red_channel_client_is_connected(rcc)) {
-@@ -199,8 +199,8 @@ void red_client_destroy(RedClient *clien
- "pthread_self (0x%" G_GSIZE_MODIFIER "x)."
- "If one of the threads is != io-thread && != vcpu-thread,"
- " this might be a BUG",
-- client->thread_id,
-- pthread_self());
-+ (unsigned long)client->thread_id,
-+ (unsigned long)pthread_self());
- }
- red_client_set_disconnecting(client);
- FOREACH_CHANNEL_CLIENT(client, rcc) {
diff --git a/meta-networking/recipes-support/spice/spice/0001-Fix-compile-errors-on-Linux-32bit-system.patch b/meta-networking/recipes-support/spice/spice/0001-Fix-compile-errors-on-Linux-32bit-system.patch
deleted file mode 100644
index d04bee95fa..0000000000
--- a/meta-networking/recipes-support/spice/spice/0001-Fix-compile-errors-on-Linux-32bit-system.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-From a2af005b5d4a62839e56f42a43df793356e78f58 Mon Sep 17 00:00:00 2001
-From: "Hongzhi.Song" <hongzhi.song@windriver.com>
-Date: Tue, 4 Jun 2019 03:58:17 -0400
-Subject: [PATCH] Fix compile errors on Linux 32bit system
-
-There are folowing compile errors on Linux 32bit system:
-
-red-channel.c:207:73: error: format '%x' expects argument of type
-'unsigned int', but argument 7 has type 'long unsigned int' [-Werror=format=]
-|207| red_channel_debug(self, "thread_id 0x%" G_GSIZE_MODIFIER "x",
- ~~~~~~~~~~~~~~~~~~~~~^
- self->priv->thread_id);
- ~~~~~~~~~~~~~~~~~~~~~^
-
-On 32bit system, #define G_GSIZE_MODIFIER "". But the type of
-'self->priv->thread_id' is 'unsigned long int' which should match '%lx'
-not '%x'.
-
-So we should recovery the <0x%" G_GSIZE_MODIFIER "x"> to <0x%lx">.
-And others files modification are similar to G_GSIZE_MODIFIER.
-
-Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
----
-Upstream-Status: Submitted [https://lists.freedesktop.org/archives/spice-devel/2019-June/049285.html]
-
- server/red-channel.c | 6 +++---
- server/red-client.c | 8 ++++----
- server/red-replay-qxl.c | 2 +-
- 3 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/server/red-channel.c b/server/red-channel.c
-index f81142d..6a03ec2 100644
---- a/server/red-channel.c
-+++ b/server/red-channel.c
-@@ -202,7 +202,7 @@ red_channel_constructed(GObject *object)
- {
- RedChannel *self = RED_CHANNEL(object);
-
-- red_channel_debug(self, "thread_id 0x%" G_GSIZE_MODIFIER "x", (unsigned long)self->priv->thread_id);
-+ red_channel_debug(self, "thread_id 0x%lx", (unsigned long)self->priv->thread_id);
-
- RedChannelClass *klass = RED_CHANNEL_GET_CLASS(self);
-
-@@ -473,8 +473,8 @@ void red_channel_remove_client(RedChannel *channel, RedChannelClient *rcc)
-
- if (!pthread_equal(pthread_self(), channel->priv->thread_id)) {
- red_channel_warning(channel,
-- "channel->thread_id (0x%" G_GSIZE_MODIFIER "x) != "
-- "pthread_self (0x%" G_GSIZE_MODIFIER "x)."
-+ "channel->thread_id (0x%lx) != "
-+ "pthread_self (0x%lx)."
- "If one of the threads is != io-thread && != vcpu-thread, "
- "this might be a BUG",
- (unsigned long)channel->priv->thread_id,
-diff --git a/server/red-client.c b/server/red-client.c
-index 2b859cb..ff4da2a 100644
---- a/server/red-client.c
-+++ b/server/red-client.c
-@@ -174,8 +174,8 @@ void red_client_migrate(RedClient *client)
- RedChannel *channel;
-
- if (!pthread_equal(pthread_self(), client->thread_id)) {
-- spice_warning("client->thread_id (0x%" G_GSIZE_MODIFIER "x) != "
-- "pthread_self (0x%" G_GSIZE_MODIFIER "x)."
-+ spice_warning("client->thread_id (0x%lx) != "
-+ "pthread_self (0x%lx)."
- "If one of the threads is != io-thread && != vcpu-thread,"
- " this might be a BUG",
- (unsigned long)client->thread_id, (unsigned long)pthread_self());
-@@ -193,8 +193,8 @@ void red_client_destroy(RedClient *client)
- RedChannelClient *rcc;
-
- if (!pthread_equal(pthread_self(), client->thread_id)) {
-- spice_warning("client->thread_id (0x%" G_GSIZE_MODIFIER "x) != "
-- "pthread_self (0x%" G_GSIZE_MODIFIER "x)."
-+ spice_warning("client->thread_id (0x%lx) != "
-+ "pthread_self (0x%lx)."
- "If one of the threads is != io-thread && != vcpu-thread,"
- " this might be a BUG",
- (unsigned long)client->thread_id,
-diff --git a/server/red-replay-qxl.c b/server/red-replay-qxl.c
-index 6d34818..0deb406 100644
---- a/server/red-replay-qxl.c
-+++ b/server/red-replay-qxl.c
-@@ -264,7 +264,7 @@ static replay_t read_binary(SpiceReplay *replay, const char *prefix, size_t *siz
- exit(1);
- }
- if ((ret = inflate(&strm, Z_NO_FLUSH)) != Z_STREAM_END) {
-- spice_error("inflate error %d (disc: %" G_GSSIZE_FORMAT ")",
-+ spice_error("inflate error %d (disc: %li)",
- ret, *size - strm.total_out);
- if (ret == Z_DATA_ERROR) {
- /* last operation may be wrong. since we do the recording
---
-2.8.1
-
diff --git a/meta-networking/recipes-support/spice/spice/0001-configure.ac-explicitly-link-to-jpeg-lib.patch b/meta-networking/recipes-support/spice/spice/0001-configure.ac-explicitly-link-to-jpeg-lib.patch
deleted file mode 100644
index 2d05143dbf..0000000000
--- a/meta-networking/recipes-support/spice/spice/0001-configure.ac-explicitly-link-to-jpeg-lib.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 6ffd9db8e02e411bda2f421abf7951dab6cf0e38 Mon Sep 17 00:00:00 2001
-From: Hongxu Jia <hongxu.jia@windriver.com>
-Date: Fri, 5 Feb 2021 01:43:44 -0800
-Subject: [PATCH] configure.ac: explicitly link to jpeg lib
-
-Since oe has added lib jpeg to the depends, explicitly link to jpeg lib
-to workaround build failure with autoconf 2.7
-
-Upstream-Status: Inappropriate [oe specific]
-
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
----
- configure.ac | 14 +-------------
- 1 file changed, 1 insertion(+), 13 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 1ce81f91..8bbb50de 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -191,24 +191,12 @@ AC_SUBST(SSL_CFLAGS)
- AC_SUBST(SSL_LIBS)
- AS_VAR_APPEND([SPICE_REQUIRES], [" openssl"])
-
--AC_CHECK_LIB(jpeg, jpeg_destroy_decompress,
-- AC_MSG_CHECKING([for jpeglib.h])
-- AC_TRY_CPP(
--[#include <stdio.h>
--#undef PACKAGE
--#undef VERSION
--#undef HAVE_STDLIB_H
--#include <jpeglib.h>],
-- JPEG_LIBS='-ljpeg'
-- AC_MSG_RESULT($jpeg_ok),
-- AC_MSG_ERROR([jpeglib.h not found])),
-- AC_MSG_ERROR([libjpeg not found]))
-+JPEG_LIBS='-ljpeg'
- AC_SUBST(JPEG_LIBS)
-
- AC_CHECK_LIB(z, deflate, Z_LIBS='-lz', AC_MSG_ERROR([zlib not found]))
- AC_SUBST(Z_LIBS)
-
--
- AC_ARG_ENABLE([manual],
- AS_HELP_STRING([--enable-manual=@<:@auto/yes/no@:>@],
- [Build SPICE manual]),
---
-2.29.2
-
diff --git a/meta-networking/recipes-support/spice/spice_git.bb b/meta-networking/recipes-support/spice/spice_git.bb
index 9c6baccc7c..419316a26e 100644
--- a/meta-networking/recipes-support/spice/spice_git.bb
+++ b/meta-networking/recipes-support/spice/spice_git.bb
@@ -10,50 +10,39 @@ environment - not only on its computer-server machine, but also from \
anywhere on the Internet and using a wide variety of machine \
architectures."
-LICENSE = "BSD & LGPLv2.1+"
+LICENSE = "LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
-PV = "0.14.2+git${SRCPV}"
+PV = "0.15.2"
-SRCREV_spice = "7cbd70b931db76c69c89c2d9d5d704f67381a81b"
-SRCREV_spice-common = "4fc4c2db36c7f07b906e9a326a9d3dc0ae6a2671"
+SRCREV = "0c2c1413a8b387ea597a95b6c867470a7c56c8ab"
-SRCREV_FORMAT = "spice_spice-common"
-
-SRC_URI = " \
- git://anongit.freedesktop.org/spice/spice;name=spice;branch=master \
- git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common;branch=master \
- file://0001-Convert-pthread_t-to-be-numeric.patch \
- file://0001-Fix-compile-errors-on-Linux-32bit-system.patch \
- file://0001-configure.ac-explicitly-link-to-jpeg-lib.patch \
-"
+SRC_URI = "gitsm://gitlab.freedesktop.org/spice/spice;branch=master;protocol=https"
S = "${WORKDIR}/git"
-inherit autotools gettext python3native python3-dir pkgconfig
+CVE_STATUS[CVE-2018-10893] = "fixed-version: patched already, caused by inaccurate CPE in the NVD database."
+
+inherit meson gettext python3native python3-dir pkgconfig
-DEPENDS += "spice-protocol jpeg pixman alsa-lib glib-2.0 python3-pyparsing-native python3-six-native glib-2.0-native"
+DEPENDS = "spice-protocol jpeg pixman alsa-lib glib-2.0 gdk-pixbuf lz4 orc python3-pyparsing-native python3-six-native glib-2.0-native zlib"
DEPENDS:append:class-nativesdk = " nativesdk-openssl"
export PYTHON="${STAGING_BINDIR_NATIVE}/python3-native/python3"
-CFLAGS:append = " -Wno-error"
+do_configure:prepend() {
+ echo ${PV} > ${S}/.tarball-version
+}
PACKAGECONFIG:class-native = ""
PACKAGECONFIG:class-nativesdk = ""
-PACKAGECONFIG ?= "sasl"
+PACKAGECONFIG ?= "sasl opus smartcard gstreamer"
-PACKAGECONFIG[celt051] = "--enable-celt051,--disable-celt051,celt051"
-PACKAGECONFIG[smartcard] = "--enable-smartcard,--disable-smartcard,libcacard,"
-PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,"
-PACKAGECONFIG[client] = "--enable-client,--disable-client,,"
-PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,,"
-PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus,"
-PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,,"
-PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama,"
+PACKAGECONFIG[gstreamer] = "-Dgstreamer=1.0,-Dgstreamer=no,gstreamer1.0 gstreamer1.0-plugins-base"
+PACKAGECONFIG[smartcard] = "-Dsmartcard=enabled,-Dsmartcard=disabled,libcacard,libcacard"
+PACKAGECONFIG[sasl] = "-Dsasl=true,-Dsasl=false,cyrus-sasl,"
+PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus,"
-COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
+COMPATIBLE_HOST = '(x86_64|i.86|aarch64).*-linux'
BBCLASSEXTEND = "native nativesdk"
-
-EXTRA_OECONF:append:toolchain-clang = " --disable-werror"
diff --git a/meta-networking/recipes-support/spice/usbredir_0.9.0.bb b/meta-networking/recipes-support/spice/usbredir_0.13.0.bb
index 5245f95f5c..3a73f9b189 100644
--- a/meta-networking/recipes-support/spice/usbredir_0.9.0.bb
+++ b/meta-networking/recipes-support/spice/usbredir_0.13.0.bb
@@ -1,20 +1,18 @@
SUMMARY = "usbredir libraries and utilities"
-LICENSE = "GPLv2+ & LGPLv2.1+"
+LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://COPYING.LIB;md5=4b54a1fd55a448865a0b32d41598759d \
"
-DEPENDS = "libusb1"
+DEPENDS = "libusb1 glib-2.0"
-SRCREV = "bca484fc6f206ab9da2f73e8a0118fad45374d4e"
+SRCREV = "5fc0e1c43194d948545941d408f4c10d084eb6ed"
-SRC_URI = " \
- git://anongit.freedesktop.org/spice/usbredir;branch=master \
-"
+SRC_URI = "git://gitlab.freedesktop.org/spice/usbredir;branch=main;protocol=https"
S = "${WORKDIR}/git"
-inherit autotools pkgconfig
+inherit meson pkgconfig
BBCLASSEXTEND = "native nativesdk"