aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch
new file mode 100644
index 0000000000..96f162dd94
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Submitted
+
+This patch adds support for arm32.
+
+Signed-off-by: Chunrong Guo <B40290@freescale.com>
+
+--- a/Makefileold 2014-06-17 21:55:23.131058918 -0500
++++ b/Makefile 2014-06-17 21:56:08.726098531 -0500
+@@ -59,6 +59,12 @@
+ TMPLIB32 = lib
+ CPPFLAGS += -DPPC_NO_SEGMENTS
+ else
++ifeq ($(ARCH),arm)
++CC32 = $(CC)
++TMPLIB32 = lib
++ELF32 += armelf_linux_eabi
++CUSTOM_LDSCRIPTS = no
++else
+ ifeq ($(ARCH),armv7l)
+ CC32 = $(CC)
+ TMPLIB32 = lib
+@@ -116,6 +122,7 @@
+ endif
+ endif
+ endif
++endif
+
+ ifdef CC32
+ OBJDIRS += obj32