aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/toybox
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/toybox')
-rw-r--r--meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb10
-rw-r--r--meta-oe/recipes-core/toybox/toybox_0.8.11.bb (renamed from meta-oe/recipes-core/toybox/toybox_0.8.4.bb)17
2 files changed, 13 insertions, 14 deletions
diff --git a/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb b/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
index f82f8e9ce2..4cad7dce11 100644
--- a/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
+++ b/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
@@ -1,6 +1,6 @@
SUMMARY = "Toybox Inittab Configuration"
-LICENSE = "BSD-0-Clause"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-0-Clause;md5=81eeb0083e31f11ab1e33ded846d521c"
+LICENSE = "0BSD"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/0BSD;md5=f667a3c3830a55a17ec3067709f4526c"
# Unpack to ${S}/orig
#
@@ -12,7 +12,7 @@ SRC_URI = "\
PACKAGE_ARCH = "${MACHINE_ARCH}"
-RCONFLICTS_${PN} = "\
+RCONFLICTS:${PN} = "\
busybox-inittab \
sysvinit-inittab \
"
@@ -34,7 +34,7 @@ do_configure() {
cp orig/* .
for config in ${PACKAGECONFIG_CONFARGS}; do
- if [[ ${config} == "enable_getty" ]]; then
+ if [ "${config}" = "enable_getty" ]; then
echo "# generated by bitbake recipe ${PN}" >> ${S}/inittab
for console in "${SERIAL_CONSOLES}"; do
param=$(echo ${console} | sed s/\;/\ /g)
@@ -56,7 +56,7 @@ do_install() {
install -D -m 0744 ${S}/rcS ${D}${sysconfdir}/init.d/rcS
}
-FILES_${PN} = "\
+FILES:${PN} = "\
${sysconfdir}/inittab \
${sysconfdir}/init.d/rcK \
${sysconfdir}/init.d/rcS \
diff --git a/meta-oe/recipes-core/toybox/toybox_0.8.4.bb b/meta-oe/recipes-core/toybox/toybox_0.8.11.bb
index cc98b9ec07..db071a1995 100644
--- a/meta-oe/recipes-core/toybox/toybox_0.8.4.bb
+++ b/meta-oe/recipes-core/toybox/toybox_0.8.11.bb
@@ -2,18 +2,17 @@ SUMMARY = "Toybox combines common utilities together into a single executable."
HOMEPAGE = "http://www.landley.net/toybox/"
DEPENDS = "attr virtual/crypt"
-LICENSE = "BSD-0-Clause"
+LICENSE = "0BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=78659a599b9325da368f2f1eb88f19c7"
inherit cml1 update-alternatives
-SRC_URI = "http://www.landley.net/toybox/downloads/${BPN}-${PV}.tar.gz \
- "
-SRC_URI[sha256sum] = "cb2a565a8d30015d08d73628795dca51a85b99b149aeabbbecd9e8dbdbd8fddc"
+SRC_URI = "http://www.landley.net/toybox/downloads/${BPN}-${PV}.tar.gz"
+SRC_URI[sha256sum] = "15aa3f832f4ec1874db761b9950617f99e1e38144c22da39a71311093bfe67dc"
SECTION = "base"
-RDEPENDS_${PN} = "${@["", "toybox-inittab"][(d.getVar('VIRTUAL-RUNTIME_init_manager') == 'toybox')]}"
+RDEPENDS:${PN} = "${@["", "toybox-inittab"][(d.getVar('VIRTUAL-RUNTIME_init_manager') == 'toybox')]}"
TOYBOX_BIN = "generated/unstripped/toybox"
@@ -24,7 +23,7 @@ TOYBOX_BIN = "generated/unstripped/toybox"
# CROSS_COMPILE = compiler prefix
CFLAGS += "${TOOLCHAIN_OPTIONS} ${TUNE_CCARGS}"
-COMPILER_toolchain-clang = "clang"
+COMPILER:toolchain-clang = "clang"
COMPILER ?= "gcc"
PACKAGECONFIG ??= "no-iconv no-getconf"
@@ -45,7 +44,7 @@ do_configure() {
fi
# Copy defconfig to .config if .config does not exist. This allows
- # recipes to manage the .config themselves in do_configure_prepend().
+ # recipes to manage the .config themselves in do_configure:prepend().
if [ -f "${WORKDIR}/defconfig" ] && [ ! -f "${B}/.config" ]; then
cp "${WORKDIR}/defconfig" "${B}/.config"
fi
@@ -95,7 +94,7 @@ do_install() {
# over busybox where possible but not over other packages
ALTERNATIVE_PRIORITY = "60"
-python do_package_prepend () {
+python do_package:prepend () {
# Read links from /etc/toybox.links and create appropriate
# update-alternatives variables
@@ -107,7 +106,7 @@ python do_package_prepend () {
for alt_link_name in f:
alt_link_name = alt_link_name.strip()
alt_name = os.path.basename(alt_link_name)
- d.appendVar('ALTERNATIVE_%s' % (pn), ' ' + alt_name)
+ d.appendVar('ALTERNATIVE:%s' % (pn), ' ' + alt_name)
d.setVarFlag('ALTERNATIVE_LINK_NAME', alt_name, alt_link_name)
d.setVarFlag('ALTERNATIVE_TARGET', alt_name, target)
f.close()