aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb')
-rw-r--r--meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb b/meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb
new file mode 100644
index 0000000000..8bd0992bd6
--- /dev/null
+++ b/meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Doxygen is the de facto standard tool for generating documentation from annotated C++ sources."
+HOMEPAGE = "http://www.doxygen.org/"
+
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "flex-native bison-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.src.tar.gz \
+ file://0001-build-don-t-look-for-Iconv.patch \
+"
+SRC_URI:append:class-native = " file://doxygen-native-only-check-python3.patch"
+SRC_URI[sha256sum] = "f352dbc3221af7012b7b00935f2dfdc9fb67a97d43287d2f6c81c50449d254e0"
+
+inherit cmake python3native
+
+EXTRA_OECMAKE += "\
+ -DFLEX_TARGET_ARG_COMPILE_FLAGS='--noline' \
+ -DBISON_TARGET_ARG_COMPILE_FLAGS='--no-lines' \
+"
+BBCLASSEXTEND = "native nativesdk"