aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/jq/jq_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/jq/jq_git.bb')
-rw-r--r--meta-oe/recipes-devtools/jq/jq_git.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-oe/recipes-devtools/jq/jq_git.bb b/meta-oe/recipes-devtools/jq/jq_git.bb
deleted file mode 100644
index c6634cd300..0000000000
--- a/meta-oe/recipes-devtools/jq/jq_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-SUMMARY = "Lightweight and flexible command-line JSON processor"
-DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \
- filter and map and transform structured data with the same \
- ease that sed, awk, grep and friends let you play with text."
-HOMEPAGE = "https://stedolan.github.io/jq/"
-BUGTRACKER = "https://github.com/stedolan/jq/issues"
-SECTION = "utils"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=2814b59e00e7918c864fa3b6bbe049b4"
-
-PV = "1.6+git${SRCPV}"
-SRC_URI = "git://github.com/stedolan/jq;protocol=https;branch=master \
- file://0001-configure-Pass-_XOPEN_SOURCE-when-checking-for-strpt.patch \
- file://0002-builtin-Replace-_BSD_SOURCE-with-_DEFAULT_SOURCE.patch \
- file://run-ptest \
- "
-SRCREV = "cff5336ec71b6fee396a95bb0e4bea365e0cd1e8"
-S = "${WORKDIR}/git"
-
-inherit autotools-brokensep ptest
-
-PACKAGECONFIG ?= "oniguruma"
-
-PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,ruby-native"
-PACKAGECONFIG[maintainer-mode] = "--enable-maintainer-mode,--disable-maintainer-mode,flex-native bison-native"
-PACKAGECONFIG[oniguruma] = "--with-oniguruma,--without-oniguruma,onig"
-
-EXTRA_OECONF += " \
- --disable-valgrind \
-"
-
-do_install_ptest() {
- cp -rf ${B}/tests ${D}${PTEST_PATH}
- cp -rf ${B}/.libs ${D}${PTEST_PATH}
- # libjq.so.* is packaged in the main jq component, so remove it from ptest
- rm -f ${D}${PTEST_PATH}/.libs/libjq.so.*
- ln -sf ${bindir}/jq ${D}${PTEST_PATH}
-}
-
-BBCLASSEXTEND = "native"