aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/kconfig-frontends
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/kconfig-frontends')
-rw-r--r--meta-oe/recipes-devtools/kconfig-frontends/files/0001-Avoid-using-hard-coded-usr-include-paths.patch33
-rw-r--r--meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb11
2 files changed, 39 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/kconfig-frontends/files/0001-Avoid-using-hard-coded-usr-include-paths.patch b/meta-oe/recipes-devtools/kconfig-frontends/files/0001-Avoid-using-hard-coded-usr-include-paths.patch
new file mode 100644
index 0000000000..ac20e9b88e
--- /dev/null
+++ b/meta-oe/recipes-devtools/kconfig-frontends/files/0001-Avoid-using-hard-coded-usr-include-paths.patch
@@ -0,0 +1,33 @@
+From 2bd01e844096ab4ecaaab8eccfbfdc721a136d01 Mon Sep 17 00:00:00 2001
+From: Mark Hatle <mark.hatle@amd.com>
+Date: Tue, 22 Aug 2023 12:28:01 -0600
+Subject: [PATCH] Avoid using hard coded /usr/include paths
+
+The system could end up using an include path that points to the host
+system instead of the sysroot. Force the system to use the sysroot.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Mark Hatle <mark.hatle@amd.com>
+---
+ configure.ac | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 150bc50..4dc684f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -344,10 +344,6 @@ AS_IF(
+ [test "$need_panel_menu" = "yes" -o "$need_panel_menu" = "auto"],
+ [AC_SUBST([ncurses_nconf_CPPFLAGS])
+ AC_SUBST([ncurses_panel_menu_LIBS])
+- AS_CASE(
+- [$CURSES_LOC],
+- [ncursesw/*],[ncurses_nconf_CPPFLAGS="-I/usr/include/ncursesw"],
+- [ncurses/*],[ncurses_nconf_CPPFLAGS="-I/usr/include/ncurses"])
+ LIBS_old="$LIBS"
+ LIBS=
+ AC_SEARCH_LIBS(
+--
+2.34.1
+
diff --git a/meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb b/meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb
index ec959d27da..b894f0ba03 100644
--- a/meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb
+++ b/meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb
@@ -8,25 +8,26 @@ kconfig infrastructure, ready for use by third-party projects. \
The kconfig-frontends package provides the kconfig parser, as well as all \
the frontends"
HOMEPAGE = "https://gitlab.com/ymorin/kconfig-frontends"
-LICENSE = "GPL-2.0"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
SECTION = "devel"
DEPENDS += "ncurses flex-native gperf-native bison-native"
-RDEPENDS_${PN} += "python3 bash"
+RDEPENDS:${PN} += "python3 bash"
SRC_URI = "git://gitlab.com/ymorin/kconfig-frontends.git;protocol=https;branch=4.11.x \
file://0001-Makefile-ensure-frontends-exits-before-writing-into-.patch \
- file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch"
+ file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch \
+ file://0001-Avoid-using-hard-coded-usr-include-paths.patch"
SRCREV = "f22fce3a308be1c7790ebefc6bbedb33c5f7c86a"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
-do_configure_prepend () {
+do_configure:prepend () {
mkdir -p ${S}/scripts/.autostuff/m4
}
-do_install_append() {
+do_install:append() {
ln -s kconfig-conf ${D}${bindir}/conf
ln -s kconfig-mconf ${D}${bindir}/mconf
}