aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/msgpack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/msgpack')
-rw-r--r--meta-oe/recipes-devtools/msgpack/msgpack-c_6.0.0.bb (renamed from meta-oe/recipes-devtools/msgpack/msgpack-c_3.2.1.bb)9
-rw-r--r--meta-oe/recipes-devtools/msgpack/msgpack-cpp_6.1.0.bb21
2 files changed, 25 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/msgpack/msgpack-c_3.2.1.bb b/meta-oe/recipes-devtools/msgpack/msgpack-c_6.0.0.bb
index 5224f32b03..40d997a52c 100644
--- a/meta-oe/recipes-devtools/msgpack/msgpack-c_3.2.1.bb
+++ b/meta-oe/recipes-devtools/msgpack/msgpack-c_6.0.0.bb
@@ -7,15 +7,14 @@ LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \
file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \
"
-PV .= "+git${SRCPV}"
-
-SRC_URI = "git://github.com/msgpack/msgpack-c \
+SRC_URI = "git://github.com/msgpack/msgpack-c;branch=c_master;protocol=https \
"
-# cpp-3.2.1
-SRCREV = "8085ab8721090a447cf98bb802d1406ad7afe420"
+SRCREV = "8160ede5e20fd3019a77eea46d9c72cf6163f802"
S = "${WORKDIR}/git"
inherit cmake pkgconfig
+EXTRA_OECMAKE += "-DMSGPACK_BUILD_TESTS=off"
+
BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-oe/recipes-devtools/msgpack/msgpack-cpp_6.1.0.bb b/meta-oe/recipes-devtools/msgpack/msgpack-cpp_6.1.0.bb
new file mode 100644
index 0000000000..5f5507bc74
--- /dev/null
+++ b/meta-oe/recipes-devtools/msgpack/msgpack-cpp_6.1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "MessagePack implementation for C and C++"
+DESCRIPTION = "MessagePack is an efficient binary serialization format. It's like JSON. but fast and small"
+HOMEPAGE = "http://msgpack.org/index.html"
+LICENSE = "BSL-1.0"
+LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \
+ file://COPYING;md5=0639c4209b6f2abf1437c813b208f2d3 \
+ file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \
+ "
+
+SRC_URI = "https://github.com/msgpack/msgpack-c/releases/download/cpp-${PV}/msgpack-cxx-${PV}.tar.gz"
+SRC_URI[sha256sum] = "23ede7e93c8efee343ad8c6514c28f3708207e5106af3b3e4969b3a9ed7039e7"
+
+S = "${WORKDIR}/msgpack-cxx-${PV}"
+
+DEPENDS += "boost"
+
+inherit cmake pkgconfig
+
+RDEPENDS:${PN}-dev = ""
+
+BBCLASSEXTEND += "native nativesdk"