aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/glog/glog_0.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/glog/glog_0.5.0.bb')
-rw-r--r--meta-oe/recipes-support/glog/glog_0.5.0.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/glog/glog_0.5.0.bb b/meta-oe/recipes-support/glog/glog_0.5.0.bb
index c4ba9f244f..40199343ee 100644
--- a/meta-oe/recipes-support/glog/glog_0.5.0.bb
+++ b/meta-oe/recipes-support/glog/glog_0.5.0.bb
@@ -18,16 +18,16 @@ S = "${WORKDIR}/git"
inherit cmake
PACKAGECONFIG ?= "shared unwind"
-PACKAGECONFIG_remove_riscv64 = "unwind"
-PACKAGECONFIG_remove_riscv32 = "unwind"
-PACKAGECONFIG_append_libc-musl_riscv64 = " execinfo"
-PACKAGECONFIG_append_libc-musl_riscv32 = " execinfo"
+PACKAGECONFIG:remove:riscv64 = "unwind"
+PACKAGECONFIG:remove:riscv32 = "unwind"
+PACKAGECONFIG:append:libc-musl:riscv64 = " execinfo"
+PACKAGECONFIG:append:libc-musl:riscv32 = " execinfo"
PACKAGECONFIG[unwind] = "-DWITH_UNWIND=ON,-DWITH_UNWIND=OFF,libunwind,libunwind"
PACKAGECONFIG[execinfo] = ",,libexecinfo"
PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,,"
-do_configure_append() {
+do_configure:append() {
# remove WORKDIR info to improve reproducibility
if [ -f "${B}/config.h" ] ; then
sed -i 's/'$(echo ${WORKDIR} | sed 's_/_\\/_g')'/../g' ${B}/config.h