aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libutempter
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libutempter')
-rw-r--r--meta-oe/recipes-support/libutempter/libutempter/0001-Fix-macro-error.patch7
-rw-r--r--meta-oe/recipes-support/libutempter/libutempter/0002-Proper-macro-path-generation.patch2
-rw-r--r--meta-oe/recipes-support/libutempter/libutempter/libutempter-remove-glibc-assumption.patch81
-rw-r--r--meta-oe/recipes-support/libutempter/libutempter_1.2.2-alt1.bb (renamed from meta-oe/recipes-support/libutempter/libutempter.bb)10
4 files changed, 7 insertions, 93 deletions
diff --git a/meta-oe/recipes-support/libutempter/libutempter/0001-Fix-macro-error.patch b/meta-oe/recipes-support/libutempter/libutempter/0001-Fix-macro-error.patch
index 8140ea3438..00119af11c 100644
--- a/meta-oe/recipes-support/libutempter/libutempter/0001-Fix-macro-error.patch
+++ b/meta-oe/recipes-support/libutempter/libutempter/0001-Fix-macro-error.patch
@@ -11,15 +11,13 @@ Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com>
iface.c | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
-diff --git a/iface.c b/iface.c
-index 5951d81..27793f0 100644
--- a/iface.c
+++ b/iface.c
@@ -43,7 +43,14 @@
__result; }))
#endif
--#define UTEMPTER_DEFAULT_PATHNAME LIBEXECDIR "/utempter/utempter"
+-#define UTEMPTER_DEFAULT_PATHNAME LIBEXECDIR "/utempter/utempter"
+#ifdef LIBEXECDIR
+# define CAT_PATH(DIR1,DIR2) DIR1##DIR2
+# define RAW_UTEMPTER_PATH CAT_PATH(LIBEXECDIR,/utempter/utempter)
@@ -31,6 +29,3 @@ index 5951d81..27793f0 100644
static const char *utempter_pathname;
static int saved_fd = -1;
---
-1.8.3.1
-
diff --git a/meta-oe/recipes-support/libutempter/libutempter/0002-Proper-macro-path-generation.patch b/meta-oe/recipes-support/libutempter/libutempter/0002-Proper-macro-path-generation.patch
index 2a866c0796..f43f54eaab 100644
--- a/meta-oe/recipes-support/libutempter/libutempter/0002-Proper-macro-path-generation.patch
+++ b/meta-oe/recipes-support/libutempter/libutempter/0002-Proper-macro-path-generation.patch
@@ -5,6 +5,8 @@ Subject: [PATCH] Proper macro path generation.
Signed-off-by: iddinev <xidinev@gmail.com>
---
+Upstream-Status: Pending
+
libutempter/iface.c | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/meta-oe/recipes-support/libutempter/libutempter/libutempter-remove-glibc-assumption.patch b/meta-oe/recipes-support/libutempter/libutempter/libutempter-remove-glibc-assumption.patch
deleted file mode 100644
index 6ed93355bb..0000000000
--- a/meta-oe/recipes-support/libutempter/libutempter/libutempter-remove-glibc-assumption.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-diff -Naur libutempter-1.1.6.orig/utempter.c libutempter-1.1.6/utempter.c
---- libutempter-1.1.6.orig/utempter.c 2010-11-04 13:14:53.000000000 -0400
-+++ libutempter-1.1.6/utempter.c 2014-06-20 16:37:09.762403323 -0400
-@@ -34,13 +34,7 @@
- #include <sys/stat.h>
- #include <utmp.h>
-
--#ifdef __GLIBC__
- # include <pty.h>
--#elif defined(__FreeBSD__)
--# include <libutil.h>
--#else
--# error Unsupported platform
--#endif /* __GLIBC__ || __FreeBSD__ */
-
- #define DEV_PREFIX "/dev/"
- #define DEV_PREFIX_LEN (sizeof(DEV_PREFIX)-1)
-@@ -106,17 +100,12 @@
-
- static int
- write_uwtmp_record(const char *user, const char *term, const char *host,
--#ifdef __GLIBC__
- pid_t pid,
--#endif
- int add)
- {
- struct utmp ut;
- struct timeval tv;
--
--#ifdef __GLIBC__
- size_t offset;
--#endif
-
- memset(&ut, 0, sizeof(ut));
-
-@@ -128,8 +117,6 @@
- if (host)
- strncpy(ut.ut_host, host, sizeof(ut.ut_host));
-
--#ifdef __GLIBC__
--
- offset = (strlen(term) <= sizeof(ut.ut_id)) ? 0 :
- strlen(term) - sizeof(ut.ut_id);
- strncpy(ut.ut_id, term + offset, sizeof(ut.ut_id));
-@@ -156,27 +143,6 @@
-
- (void) updwtmp(_PATH_WTMP, &ut);
-
--#elif defined(__FreeBSD__)
--
-- ut.ut_time = tv.tv_sec;
--
-- if (add)
-- {
-- login(&ut);
-- } else
-- {
-- if (logout(term) != 1)
-- {
--#ifdef UTEMPTER_DEBUG
-- fprintf(stderr, "utempter: logout: %s\n",
-- strerror(errno));
--#endif
-- exit(EXIT_FAILURE);
-- }
-- }
--
--#endif /* __GLIBC__ || __FreeBSD__ */
--
- #ifdef UTEMPTER_DEBUG
- fprintf(stderr,
- "utempter: DEBUG: utmp/wtmp record %s for terminal '%s'\n",
-@@ -255,8 +221,6 @@
- validate_device(device);
-
- return write_uwtmp_record(pw->pw_name, device + DEV_PREFIX_LEN, host,
--#ifdef __GLIBC__
- pid,
--#endif
- add);
- }
diff --git a/meta-oe/recipes-support/libutempter/libutempter.bb b/meta-oe/recipes-support/libutempter/libutempter_1.2.2-alt1.bb
index b178a92fe6..0d2cd135c6 100644
--- a/meta-oe/recipes-support/libutempter/libutempter.bb
+++ b/meta-oe/recipes-support/libutempter/libutempter_1.2.2-alt1.bb
@@ -4,17 +4,15 @@ This library provides interface for terminal emulators such as \
screen and xterm to record user sessions to utmp and wtmp files."
HOMEPAGE = "ftp://ftp.altlinux.org/pub/people/ldv/utempter"
SECTION = "System Environment/Libraries"
-LICENSE = "GPLv2 & GPLv2+ & LGPLv2 & MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-only & MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
-SRCREV = "3ef74fff310f09e2601e241b9f042cd39d591018"
-PV = "1.1.6-alt2+git${SRCPV}"
+SRCREV = "63825e2244629d44dae21132b1065d7ecc0491c0"
SRC_URI = "git://git.altlinux.org/people/ldv/packages/libutempter.git;branch=master \
file://0001-Fix-macro-error.patch \
file://0002-Proper-macro-path-generation.patch \
- file://libutempter-remove-glibc-assumption.patch \
- "
+ "
S = "${WORKDIR}/git/${BPN}"