aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-extended')
-rw-r--r--meta-perl/recipes-extended/logcheck/logcheck_1.4.3.bb (renamed from meta-perl/recipes-extended/logcheck/logcheck_1.3.20.bb)17
-rw-r--r--meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb6
2 files changed, 10 insertions, 13 deletions
diff --git a/meta-perl/recipes-extended/logcheck/logcheck_1.3.20.bb b/meta-perl/recipes-extended/logcheck/logcheck_1.4.3.bb
index 10b281a66b..037852392f 100644
--- a/meta-perl/recipes-extended/logcheck/logcheck_1.3.20.bb
+++ b/meta-perl/recipes-extended/logcheck/logcheck_1.4.3.bb
@@ -8,23 +8,20 @@ Normal entries are entries which match one of the many included regular \
expression files contain in the database."
SECTION = "Applications/System"
HOMEPAGE = "http://logcheck.org/"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c93c0550bd3173f4504b2cbd8991e50b"
SRC_URI = "${DEBIAN_MIRROR}/main/l/${BPN}/${BPN}_${PV}.tar.xz \
file://99_logcheck \
"
-SRC_URI[md5sum] = "1c6e9a97f9cc485353c25147cb99fb25"
-SRC_URI[sha256sum] = "9fb6d02b933470d0b1d1efb54ea186e0d0d27336f9d146be592f65ce60dfb3e6"
-
-S = "${WORKDIR}/${BPN}"
+SRC_URI[sha256sum] = "ad83ae80bd780bdae5eefd40ad59a3e97b85ad3a4962aa7c00d98ed3bdffcdd0"
inherit useradd
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "-m -g ${BPN} -G adm -r -d ${localstatedir}/lib/${BPN} \
+USERADD_PARAM:${PN} = "-m -g ${BPN} -G adm -r -d ${localstatedir}/lib/${BPN} \
-s /bin/false -c 'logcheck account' ${BPN}"
-GROUPADD_PARAM_${PN} = "-r ${BPN}"
+GROUPADD_PARAM:${PN} = "-r ${BPN}"
do_install() {
# Fix QA Issue
@@ -52,7 +49,7 @@ do_install() {
# Don't install /var/lock when populating rootfs. Do it through volatile
if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/default/volatiles
- install -m 0644 ${WORKDIR}/99_logcheck ${D}${sysconfdir}/default/volatiles
+ install -m 0644 ${UNPACKDIR}/99_logcheck ${D}${sysconfdir}/default/volatiles
fi
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/tmpfiles.d
@@ -63,7 +60,7 @@ do_install() {
VIRTUAL-RUNTIME_syslog ??= "rsyslog"
-RDEPENDS_${PN} = "\
+RDEPENDS:${PN} = "\
bash \
cronie \
debianutils-run-parts \
@@ -77,4 +74,4 @@ RDEPENDS_${PN} = "\
${VIRTUAL-RUNTIME_syslog} \
"
-FILES_${PN} += "${datadir}/logtail"
+FILES:${PN} += "${datadir}/logtail"
diff --git a/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb b/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
index 2516fbfcaa..a5d28265d7 100644
--- a/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
+++ b/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "Constructs and (by default) mails MIME messages. \
like programs."
HOMEPAGE = "http://search.cpan.org/~rosch/mime-construct/mime-construct"
SECTION = "mail"
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://debian/copyright;md5=5e2e5da619ac8ef8c84767ccc4656e96"
SRC_URI = "${CPAN_MIRROR}/authors/id/R/RO/ROSCH/mime-construct-${PV}.tar.gz \
@@ -17,11 +17,11 @@ SRC_URI[sha256sum] = "4cd7bb61b51d41192d1498c1051aa6a4ccd75aeb09b71d2ec706a7084a
inherit cpan
-RDEPENDS_${PN} += "libmime-types-perl libproc-waitstat-perl msmtp \
+RDEPENDS:${PN} += "libmime-types-perl libproc-waitstat-perl msmtp \
perl-module-filehandle perl-module-mime-base64 perl-module-mime-quotedprint perl-module-posix \
"
-do_install_append() {
+do_install:append() {
#change the interpreter in file
sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl -w|${bindir}/env perl|g" \
${D}/${bindir}/mime-construct