aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aiohttp_3.9.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aiohttp_3.9.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohttp_3.9.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.9.5.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.9.5.bb
new file mode 100644
index 0000000000..57adb1eeba
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.9.5.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Async http client/server framework"
+DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
+HOMEPAGE = "https://github.com/aio-libs/aiohttp"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=748073912af33aa59430d3702aa32d41"
+
+SRC_URI[sha256sum] = "edea7d15772ceeb29db4aff55e482d4bcfb6ae160ce144f2682de02f6d693551"
+
+PYPI_PACKAGE = "aiohttp"
+inherit python_setuptools_build_meta pypi
+
+RDEPENDS:${PN} = "\
+ python3-aiohappyeyeballs \
+ python3-aiosignal \
+ python3-async-timeout \
+ python3-attrs \
+ python3-frozenlist \
+ python3-misc \
+ python3-multidict \
+ python3-yarl \
+ python3-aiodns \
+"