aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb b/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb
index eef5c02735..ad07b3b082 100644
--- a/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb
+++ b/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb
@@ -11,11 +11,14 @@ SRC_URI[sha256sum] = "7d5d0167b2b1ba821647616af46a749d1c653740dd0d2415100fe26e27
inherit pypi setuptools3 ptest
-RDEPENDS_${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+RDEPENDS:${PN}-ptest += " \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/test
cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
}
+
+BBCLASSEXTEND = "native nativesdk"