aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cantools_39.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cantools_39.4.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cantools_39.4.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cantools_39.4.4.bb b/meta-python/recipes-devtools/python/python3-cantools_39.4.4.bb
new file mode 100644
index 0000000000..ebae6b63e6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cantools_39.4.4.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "CAN BUS tools in Python 3."
+HOMEPAGE = "https://github.com/eerimoq/cantools"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d9aa4ec07de78abae21c490c9ffe61bd"
+
+SRC_URI[sha256sum] = "6e8e918b6671a62a9f3990546ece5623e1deb71defb1cef85a9955ac301da99e"
+
+PYPI_PACKAGE = "cantools"
+
+inherit pypi python_poetry_core
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} += "\
+ python3-can \
+ python3-bitstruct \
+ python3-core \
+ python3-textparser \
+ python3-typing-extensions \
+ python3-diskcache \
+ python3-asyncio \
+"
+
+CLEANBROKEN = "1"