aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-frozenlist_1.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-frozenlist_1.4.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-frozenlist_1.4.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-frozenlist_1.4.1.bb b/meta-python/recipes-devtools/python/python3-frozenlist_1.4.1.bb
new file mode 100644
index 0000000000..4288f2922e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-frozenlist_1.4.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A list-like structure which implements collections.abc.MutableSequence, and which can be made immutable."
+HOMEPAGE = "https://github.com/aio-libs/frozenlist"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cf056e8e7a0a5477451af18b7b5aa98c"
+
+SRC_URI[sha256sum] = "c037a86e8513059a2613aaba4d817bb90b9d9b6b69aace3ce9c877e8c8ed402b"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += " \
+ python3-expandvars-native \
+ python3-cython-native \
+"
+
+BBCLASSEXTEND = "native nativesdk"