aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb b/meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb
new file mode 100644
index 0000000000..23060f3d6e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "IPython: Productive Interactive Computing"
+HOMEPAGE = "https://ipython.org"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
+
+PYPI_PACKAGE = "ipython"
+
+SRC_URI[sha256sum] = "010db3f8a728a578bb641fdd06c063b9fb8e96a9464c63aec6310fbcb5e80501"
+
+RDEPENDS:${PN} = "\
+ python3-setuptools \
+ python3-jedi \
+ python3-decorator \
+ python3-pickleshare \
+ python3-traitlets \
+ python3-prompt-toolkit \
+ python3-pygments \
+ python3-backcall \
+ python3-pydoc \
+ python3-debugger \
+ python3-pexpect \
+ python3-unixadmin \
+ python3-misc \
+ python3-sqlite3 \
+ python3-stack-data \
+"
+
+inherit setuptools3 pypi