aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb b/meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb
new file mode 100644
index 0000000000..b12e180d02
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
+HOMEPAGE = "https://github.com/aio-libs/multidict/"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b4fef6e4b0828c2401fb983363985b39"
+
+inherit pypi setuptools3 ptest
+
+PV .= "+git"
+
+SRCREV = "a9b281b2ef4ab25d95d6b268aa88c428e75c3696"
+PYPI_SRC_URI = "git://github.com/aio-libs/multidict;branch=master;protocol=https"
+S = "${WORKDIR}/git"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-pytest \
+ python3-pytest-cov \
+ python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"