aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-networkx_3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-networkx_3.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-networkx_3.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-networkx_3.1.bb b/meta-python/recipes-devtools/python/python3-networkx_3.1.bb
new file mode 100644
index 0000000000..2f2c3cfc3d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-networkx_3.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Python package for creating and manipulating graphs and networks"
+HOMEPAGE = "http://networkx.github.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4266362445d56549f7b8973d02e5f22a"
+
+SRC_URI[sha256sum] = "de346335408f84de0eada6ff9fafafff9bcda11f0a0dfaa931133debb146ab61"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ python3-decorator \
+ python3-netclient \
+ python3-compression \
+ python3-numbers \
+ python3-pickle \
+ python3-html \
+ python3-xml \
+ python3-json \
+ python3-profile \
+ python3-threading \
+ "
+
+BBCLASSEXTEND = "native nativesdk"