aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-path_16.14.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-path_16.14.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-path_16.14.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-path_16.14.0.bb b/meta-python/recipes-devtools/python/python3-path_16.14.0.bb
new file mode 100644
index 0000000000..b4d290a230
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-path_16.14.0.bb
@@ -0,0 +1,34 @@
+SUMMARY = "A module wrapper for os.path"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=141643e11c48898150daa83802dbc65f"
+
+SRC_URI[sha256sum] = "dbaaa7efd4602fd6ba8d82890dc7823d69e5de740a6e842d9919b0faaf2b6a8e"
+
+SRC_URI += "\
+ file://run-ptest \
+"
+
+inherit pypi python_setuptools_build_meta ptest
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} += " \
+ python3-appdirs \
+ python3-crypt \
+ python3-io \
+ python3-numbers \
+ python3-shell \
+"
+RDEPENDS:${PN}-ptest += " \
+ python3-pytest \
+ python3-unittest-automake-output \
+"
+
+BBCLASSEXTEND = "nativesdk native"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/test
+ cp -rf ${S}/test_* ${D}${PTEST_PATH}/test/
+ install -d ${D}${PTEST_PATH}/path
+ cp -rf ${S}/path/* ${D}${PTEST_PATH}/path/
+}